Échec de la sauvegarde de NetWorker vProxy avec le message d’erreur RPC : Failed to connect to host » et « Err : 5037- Impossible de résoudre l’adresse IP à partir de l’hôte »
Summary: L’intégration NetWorker VMware Protection (NVP) est configurée avec l’appliance vProxy. Le déploiement vProxy présentait des problèmes de résolution de noms et de DNS. Les sauvegardes de machine virtuelle (VM) pour certaines machines virtuelles échouent avec un message d’erreur de résolution de nom non valide. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
À partir du fichier /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log :
À partir de /nsr/logs/daemon.raw :
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR: [1268:7F4794001E30] ddp_connect_with_config_internal() failed, Hostname: 110DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR: [1268:7F4794001E30] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR: [1268:7F4778001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR: [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
---- Skipping Lines ----
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T13:59:20Z ERROR: [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:06:29Z INFO: [1268:7F476C001C80] ddcl_nfs_open_tcp - Timed out trying to resolve the hostname: DD###_T4
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR: [1268:7F476C001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR: [1268:7F476C001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
À partir de /nsr/logs/daemon.raw :
71193 MM/DD/YYYY HH:MM:SS AM 0 0 0 4988 4616 0 my_networker_server nsrd NSR info Media Info: Failed to start nsrsnmd on host my_storagenode_name, error `RPC error: Failed to connect to host 'my_storagenode_name': Remote system error - No connection could be made because the target machine actively refused it.
Reportez-vous à l’article 22793 de Dell NetWorker : utilisation de nsr_render_log
Cause
Problème de résolution de noms au niveau de l’hôte vProxy
Resolution
Ajoutez manuellement l’adresse IP, le FQDN, le nom abrégé de vCenter, Data Domain, NetWorker et le nœud de stockage dans /etc/hosts de l’hôte vProxy.
Démarrez les sauvegardes de la machine virtuelle vProxy dès maintenant.
Démarrez les sauvegardes de la machine virtuelle vProxy dès maintenant.
- Connectez-vous à la session vProxy PuTTY en tant qu’administrateur, puis passez à root :
sudo su - root
- Exécutez la commande suivante pour créer une entrée /etc/host
# echo "IP_of_vCenter FQDN_of_vCenter ShortName_of_vCenter" >> /etc/hosts
ÉCHANTILLON:
# echo "10.10.10.10 myvcenter.abc.com myvcenter" >> /etc/hosts
# echo "IP_of_DD FQDN_of_DD ShortName_of_DD" >> /etc/hosts
# echo "IP_of_NWServer FQDN_of_NWServer ShortName_of_NWServer" >> /etc/hosts
# echo "IP_of_StorageNode FQDN_of_StorageNode ShortName_of_StorageNode" >> /etc/hostsProducts
NetWorker FamilyArticle Properties
Article Number: 000219162
Article Type: Solution
Last Modified: 23 Oct 2024
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.