PowerEdge: iDRAC9; SWC5008: No se puede acceder al panel LED frontal debido a una condición de hardware

Summary: En este artículo, se describe un problema que afecta a los servidores PowerEdge que ejecutan iDRAC9 en los que el error SWC5008 afirma en el SEL varias veces.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Los servidores Dell PowerEdge que ejecutan iDRAC9 pueden presentar errores de SWC5008 excesivos que hacen referencia al LED frontal en los registros de eventos del sistema (SEL). SWC5008 eventos también pueden estar presentes en el registro del ciclo de vida útil de iDRAC9. Estos errores se producen por diversos motivos. En el artículo, se proporciona información general sobre la placa controladora de LED y los métodos para diagnosticar avistamientos de errores. 

Descripción:

El error de SWC5008 aparece como se muestra a continuación en la Figura 1 y en las Tablas 1 y 2.
Ejemplo de estado crítico del sistema en el panel de iDRAC9

Figura 1: Ejemplo de estado crítico del sistema en el panel de iDRAC9



Tabla 1: Ejemplo de registro de eventos del sistema (SEL)

2020-06-02 07:08:15

2

No se puede acceder al panel LED frontal debido a una condición de error de hardware.

 

Tabla 2: Ejemplo de registro de Lifecycle

2020-06-02 07:08:15

677

SWC5008

No se puede acceder al panel LED frontal debido a una condición de error de hardware.

 

 


Cause

El panel de control LED frontal izquierdo es monitoreado y administrado por la controladora iDRAC (BMC) integrada en los servidores PowerEdge. Las consultas de estado periódicas se realizan cada cinco segundos para verificar la presencia y el estado actual del panel LED frontal. La iDRAC también mantiene el firmware actual instalado en esta placa controladora. Si hay una actualización aplicable en el firmware de iDRAC, iDRAC intenta insertar la actualización del firmware LED durante los ciclos de arranque de iDRAC. En cualquiera de estas secuencias, iDRAC utiliza un circuito i2c para comunicarse con esta placa controladora de LED. Los tiempos de espera agotados en la comunicación entre iDRAC y el panel de control izquierdo durante estas secuencias provocan la SWC5008 los eventos de error registrados en el registro de SEL y Lifecycle.


Panel LED frontal PowerEdge R740XD

Figura 2: Panel de LED frontal PowerEdge R740XD

El panel de control izquierdo (LCP) está diseñado para admitir la administración en la caja o el estado del sistema de un vistazo. Se encuentra en la orejeta izquierda del chasis cuando se mira desde la parte frontal del sistema.
En la mayoría de los servidores PowerEdge, LCP se ofrece en dos opciones:

  • Botón de Quick Sync 2 o
  • Botón 1 del LED de estado 

En cualquiera de estas configuraciones de panel de control, hay cinco indicadores LED de estado para proporcionar una indicación en tiempo real, en la caja, de una falla de hardware que afecta al servidor. A continuación, en la Figura 3, se puede ver una explicación de estos LED indicadores.

Indicadores LED de estado PowerEdge

Figura 3: Indicadores LED de estado PowerEdge
 

En condiciones normales de mantenimiento del servidor, estos cinco LED aparecen apagados.

Cuando se detecta una falla de hardware en uno de los subsistemas alineados con estos LED, la retroiluminación se iluminará en un estado amarillo fijo.

Estos LED son controlados por la controladora iDRAC (BMC) a través de la comunicación en el circuito i2c. Las barras luminosas para Quick Sync y el ID del sistema no se administran a través de este mismo circuito i2c y funcionan independientemente de los LED de estado. 

 


Resolution

Dell Technologies recomienda actualizar al firmware de iDRAC9 más reciente para resolver este problema. Consulte las Versiones de iDRAC9 y las Notas de la versión para obtener el firmware de iDRAC9 más reciente disponible para el sistema. Tenga en cuenta que el firmware de iDRAC9 puede diferir de un sistema a otro.

La versión de firmware 4.22.00.53 de iDRAC9 introdujo mecanismos para recuperar las controladoras LED del panel frontal de una condición de bloqueo parcial. Estos cambios se encuentran en todas las versiones de iDRAC9 a partir de 4.32.10.00. Los cambios en esta versión no enmascararán las verdaderas fallas de hardware del panel LED frontal. Si los errores persisten una vez que se ha implementado este firmware, continúe con la solución de problemas de hardware.

Si los eventos de SWC5008 continúan grabándose después de aplicar el firmware iDRAC9 4.22.00.53 o 4.32.10.00, se debe investigar el panel LED frontal para detectar una posible falla de hardware. Los siguientes pasos de solución de problemas se deben considerar como punto de partida:

  • Verifique si hay daños en el cable de la placa de control LED frontal.
  • Vuelva a insertar el cable de la placa de control LED frontal si tiene problemas de conexión. 
  • Reemplace la placa de control del LED frontal por una falla de LED.
  • Reemplace la tarjeta madre para cualquier problema que persista.

Affected Products

iDRAC9 - 3.0x Series, iDRAC9 - 3.1x Series, iDRAC9 - 3.2x Series, iDRAC9 - 3.3x Series, iDRAC9 - 3.4x Series, iDRAC9 - 4.xx Series, OEMR R340, OEMR R350, OEMR R360, OEMR R440

Products

OEMR R450, OEMR R540, OEMR R550, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR XL R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2 , OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR XL R760, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR T340, OEMR T350, OEMR T360, OEMR T440, OEMR T550, OEMR T560, OEMR T640, OEMR XL T640, OEMR XL R240, OEMR XL R340, OEMR XL R660xs, OEMR XL R6615, OEMR XL R6625, OEMR XL R760xs, OEMR XL R7615, OEMR XL R7625, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000181333
Article Type: Solution
Last Modified: 16 Jun 2025
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.