PowerEdge: iDRAC9; SWC5008: No se puede acceder al panel LED frontal debido a una condición de hardware
Summary: En este artículo, se describe un problema que afecta a los servidores PowerEdge que ejecutan iDRAC9 en los que el error SWC5008 afirma en el SEL varias veces.
Symptoms
Los servidores Dell PowerEdge que ejecutan iDRAC9 pueden presentar errores de SWC5008 excesivos que hacen referencia al LED frontal en los registros de eventos del sistema (SEL). SWC5008 eventos también pueden estar presentes en el registro del ciclo de vida útil de iDRAC9. Estos errores se producen por diversos motivos. En el artículo, se proporciona información general sobre la placa controladora de LED y los métodos para diagnosticar avistamientos de errores.
Descripción:
El error de SWC5008 aparece como se muestra a continuación en la Figura 1 y en las Tablas 1 y 2.
Figura 1: Ejemplo de estado crítico del sistema en el panel de iDRAC9
Tabla 1: Ejemplo de registro de eventos del sistema (SEL)
|
2020-06-02 07:08:15 |
2 |
No se puede acceder al panel LED frontal debido a una condición de error de hardware. |
Tabla 2: Ejemplo de registro de Lifecycle
|
2020-06-02 07:08:15 |
677 |
SWC5008 |
No se puede acceder al panel LED frontal debido a una condición de error de hardware. |
Cause
El panel de control LED frontal izquierdo es monitoreado y administrado por la controladora iDRAC (BMC) integrada en los servidores PowerEdge. Las consultas de estado periódicas se realizan cada cinco segundos para verificar la presencia y el estado actual del panel LED frontal. La iDRAC también mantiene el firmware actual instalado en esta placa controladora. Si hay una actualización aplicable en el firmware de iDRAC, iDRAC intenta insertar la actualización del firmware LED durante los ciclos de arranque de iDRAC. En cualquiera de estas secuencias, iDRAC utiliza un circuito i2c para comunicarse con esta placa controladora de LED. Los tiempos de espera agotados en la comunicación entre iDRAC y el panel de control izquierdo durante estas secuencias provocan la SWC5008 los eventos de error registrados en el registro de SEL y Lifecycle.

Figura 2: Panel de LED frontal PowerEdge R740XD
El panel de control izquierdo (LCP) está diseñado para admitir la administración en la caja o el estado del sistema de un vistazo. Se encuentra en la orejeta izquierda del chasis cuando se mira desde la parte frontal del sistema.
En la mayoría de los servidores PowerEdge, LCP se ofrece en dos opciones:
- Botón de Quick Sync 2 o
- Botón 1 del LED de estado
En cualquiera de estas configuraciones de panel de control, hay cinco indicadores LED de estado para proporcionar una indicación en tiempo real, en la caja, de una falla de hardware que afecta al servidor. A continuación, en la Figura 3, se puede ver una explicación de estos LED indicadores.

Figura 3: Indicadores LED de estado PowerEdge
En condiciones normales de mantenimiento del servidor, estos cinco LED aparecen apagados.
Cuando se detecta una falla de hardware en uno de los subsistemas alineados con estos LED, la retroiluminación se iluminará en un estado amarillo fijo.Estos LED son controlados por la controladora iDRAC (BMC) a través de la comunicación en el circuito i2c. Las barras luminosas para Quick Sync y el ID del sistema no se administran a través de este mismo circuito i2c y funcionan independientemente de los LED de estado.
Resolution
La versión de firmware 4.22.00.53 de iDRAC9 introdujo mecanismos para recuperar las controladoras LED del panel frontal de una condición de bloqueo parcial. Estos cambios se encuentran en todas las versiones de iDRAC9 a partir de 4.32.10.00. Los cambios en esta versión no enmascararán las verdaderas fallas de hardware del panel LED frontal. Si los errores persisten una vez que se ha implementado este firmware, continúe con la solución de problemas de hardware.
Si los eventos de SWC5008 continúan grabándose después de aplicar el firmware iDRAC9 4.22.00.53 o 4.32.10.00, se debe investigar el panel LED frontal para detectar una posible falla de hardware. Los siguientes pasos de solución de problemas se deben considerar como punto de partida:
- Verifique si hay daños en el cable de la placa de control LED frontal.
- Vuelva a insertar el cable de la placa de control LED frontal si tiene problemas de conexión.
- Reemplace la placa de control del LED frontal por una falla de LED.
- Reemplace la tarjeta madre para cualquier problema que persista.