PowerEdge : iDRAC9 : SWC5008 : Impossible d’accéder au panneau LED avant car l’état du matériel
Summary: Cet article décrit un problème affectant les serveurs PowerEdge qui exécutent l’iDRAC9, dans lequel l’erreur SWC5008 s’affiche plusieurs fois dans le journal SEL.
Symptoms
Les serveurs Dell PowerEdge exécutant iDRAC9 peuvent présenter des erreurs de SWC5008 excessives faisant référence au voyant avant dans les journaux des événements système (SEL). Des événements SWC5008 peuvent également s’afficher dans le journal Lifecycle de l’iDRAC9. Ces erreurs se produisent pour différentes raisons. Cet article fournit des informations générales sur la carte du contrôleur LED et les méthodes de diagnostic des erreurs.
Description:
L’erreur SWC5008 s’affiche comme indiqué ci-dessous dans la Figure 1 et les Tableaux 1 et 2.
Figure 1 : Exemple d’intégrité du système critique du tableau de bord iDRAC9
Tableau 1 : Exemple de journal des événements système (SEL)
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2020-06-02 07:08:15 |
2 |
Impossible d’accéder au panneau de voyants avant en raison d’une erreur matérielle. |
Tableau 2 : Exemple de journal Lifecycle
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677 |
SWC5008 |
Impossible d’accéder au panneau de voyants avant en raison d’une erreur matérielle. |
Cause
Le panneau de contrôle des voyants avant gauche est surveillé et géré par le contrôleur iDRAC (BMC) intégré sur les serveurs PowerEdge. Des requêtes d’état régulières se produisent toutes les cinq secondes pour vérifier la présence et l’intégrité actuelle du panneau LED avant. L’iDRAC maintient également le firmware installé sur la carte de contrôle. S’il existe une mise à jour applicable dans le firmware de l’iDRAC, l’iDRAC tente de transmettre la mise à jour du firmware LED pendant les cycles de démarrage de l’iDRAC. Dans l’une ou l’autre de ces séquences, l’iDRAC utilise un circuit i2c pour communiquer avec la carte de contrôle des voyants. Les délais d’attente pour la communication entre l’iDRAC et le panneau de contrôle gauche durant ces séquences génèrent les événements d’erreur SWC5008 consignés dans le journal SEL et le journal Lifecycle.

Figure 2 : Panneau LED avant PowerEdge R740XD
Le panneau de configuration gauche (LCP) est conçu pour prendre en charge la gestion au niveau du boîtier ou l’intégrité du système en un coup d’œil. Elle se trouve sur le côté gauche du châssis lorsque l’utilisateur regarde l’avant du système.
Sur la plupart des serveurs PowerEdge, le LCP est proposé avec deux options :
- Bouton Quick Sync 2 ou
- Bouton d’état du voyant 1
Dans ces deux configurations de panneau de contrôle, il existe cinq voyants d’état permettant d’indiquer en temps réel une défaillance matérielle affectant le serveur. Vous trouverez des explications sur ces voyants dans la Figure 3.

Figure 3 : Voyants d’état des serveurs PowerEdge
Dans des conditions normales d’intégrité du serveur, ces cinq voyants sont éteints.
Lorsqu’une panne matérielle est détectée sur l’un des sous-systèmes alignés avec ces voyants, le rétroéclairage s’allume en orange fixe.Ces voyants sont contrôlés par le contrôleur de l’iDRAC (BMC) via la communication sur le circuit i2c. Les barres lumineuses des boutons Quick Sync et de l’ID du système ne sont pas gérées par ce circuit i2c et fonctionnent indépendamment des voyants d’état.
Resolution
La version 4.22.00.53 du firmware iDRAC9 a introduit des mécanismes pour restaurer les contrôleurs LED du panneau avant d’une condition de verrouillage logiciel. Ces modifications concernent toutes les versions d’iDRAC9 à partir de la version 4.32.10.00. Les modifications apportées à cette version ne masquent pas les véritables défaillances matérielles du panneau LED avant. Si des erreurs persistent alors que ce firmware a été installé, continuez à résoudre les problèmes liés au matériel.
Si des événements SWC5008 continuent d’être enregistrés après l’application du firmware de l’iDRAC9 version 4.22.00.53 ou 4.32.10.00, le panneau des voyants avant doit être examiné pour détecter les pannes matérielles possibles. Les étapes de dépannage suivantes doivent être considérées comme un point de départ :
- Vérifiez si le câble de la carte de contrôle des voyants avant est endommagé.
- Rebranchez le câble de la carte de contrôle des voyants avant pour voir s’il existe des problèmes de connexion.
- Remettez en place la carte de contrôle des voyants avant pour voir s’il existe une défaillance des voyants.
- Remplacez la carte système si les problèmes persistent.