PowerEdge: iDRAC9: SWC5008: Nie można uzyskać dostępu do przedniego panelu LED z powodu stanu sprzętu

Summary: W tym artykule opisano problem mający wpływ na serwery PowerEdge z kontrolerem iDRAC9, na którym wielokrotnie występuje błąd SWC5008.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Serwery Dell PowerEdge z kontrolerem iDRAC9 mogą wykazywać nadmierną liczbę błędów SWC5008 odnoszących się do przedniej diody LED w dziennikach zdarzeń systemu (SEL). Zdarzenia SWC5008 mogą również być obecne w dzienniku cyklu eksportacji kontrolera iDRAC9. Błędy te występują z różnych przyczyn. Ten artykuł zawiera podstawowe informacje dotyczące płyty kontrolera LED i metod diagnozowania błędów. 

Description:

Błąd SWC5008 pojawia się jak na rysunku 1 oraz w tabelach 1 i 2.
Pulpit nawigacyjny kontrolera iDRAC9 — przykład krytycznego stanu systemu

Rysunek 1. Pulpit nawigacyjny kontrolera iDRAC9 — przykład krytycznej kondycji systemu



Tabela 1: Przykładowy wpis dziennika zdarzeń systemowych (SEL)

2020-06-02 07:08:15

2

Błąd Unable to access Front LED Panel because of a hardware error condition.

 

Tabela 2: Przykładowy wpis dziennika cyklu eksploatacji

2020-06-02 07:08:15

677

SWC5008

Błąd Unable to access Front LED Panel because of a hardware error condition.

 

 


Cause

Przedni lewy panel sterowania diodami LED jest monitorowany i zarządzany przez kontroler iDRAC (BMC) wbudowany w serwery PowerEdge. Co pięć sekund regularnie wysyłane są zapytania o stan w celu sprawdzenia obecności i bieżącej kondycji przedniego panelu LED. Kontroler iDRAC obsługuje także obecnie zainstalowane oprogramowanie wewnętrzne na tej płycie kontrolera. Jeśli w oprogramowaniu wewnętrznym kontrolera iDRAC znajduje się odpowiednia aktualizacja, kontroler iDRAC próbuje przesłać aktualizację oprogramowania wewnętrznego przy pomocy lampki LED podczas cykli rozruchu kontrolera iDRAC. Niezależnie od sekwencji kontroler iDRAC komunikuje się z płytą kontrolera LED przy użyciu obwodu i2c. Przekraczanie limitów czasu podczas komunikacji między kontrolerem iDRAC i lewym panelem sterowania w trakcie tych sekwencji prowadzi do rejestrowania zdarzeń o błędzie SWC5008 w dzienniku SEL i cyklu eksploatacji.


Przedni panel LED PowerEdge R740XD

Rysunek 2. Przedni panel LED PowerEdge R740XD

Lewy panel kontrolny (LCP) służy do szybkiego wdrażania zarządzania i kondycji systemu. Jest on umieszczony po lewej stronie obudowy, patrząc z przodu.
W przypadku większości serwerów PowerEdge panel LCP jest oferowany w dwóch konfiguracjach:

  • Przycisk szybkiego synchronizowania 2 lub
  • przycisk Dioda LED stanu 1 

W obu konfiguracjach panel sterowania ma pięć wskaźników LED stanu, które bezpośrednio dostarczają informacje na temat awarii sprzętu serwera w czasie rzeczywistym. Objaśnienia tych wskaźników LED można zobaczyć poniżej na Rysunku 3.

Wskaźniki LED kondycji serwera PowerEdge

Rysunek 3. Wskaźniki LED kondycji serwera PowerEdge
 

W normalnych warunkach kondycji serwera tych pięć diod LED wydaje się wyłączonych.

W przypadku wykrycia awarii sprzętowej w jednym z podsystemów powiązanych z tymi diodami LED podświetlenie zaświeci się ciągłym pomarańczowym światłem.

Diody LED są kontrolowane przez kontroler iDRAC (BMC) poprzez komunikację na obwodzie i2c. Płaskie lampki szybkiej synchronizacji i identyfikatora systemu nie są zarządzane przez ten sam obwód i2c i działają niezależnie od wskaźników LED stanu. 

 


Resolution

Aby rozwiązać ten problem, firma Dell Technologies zaleca uaktualnienie do najnowszej wersji oprogramowania wewnętrznego kontrolera iDRAC9. Najnowsze oprogramowanie wewnętrzne kontrolera iDRAC9 dostępne dla Twojego systemu można znaleźć w wersjach i informacjach dotyczących wydania kontrolera iDRAC9. Uwaga: oprogramowanie wewnętrzne kontrolera iDRAC9 może się różnić w zależności od systemu.

W oprogramowaniu wewnętrznym kontrolera iDRAC9 w wersji 4.22.00.53 wprowadzono mechanizmy odzyskiwania kontrolerów LED panelu przedniego po miękkim zablokowaniu. Te zmiany dotyczą wszystkich wersji kontrolera iDRAC9 począwszy od wersji 4.32.10.00. Zmiany wprowadzone w tej wersji nie maskują rzeczywistych awarii sprzętowych przedniego panelu LED. Jeśli błędy będą się powtarzać po wdrożeniu nowego oprogramowania wewnętrznego, kontynuuj rozwiązywanie problemów ze sprzętem.

Jeśli zdarzenia SWC5008 będą nadal rejestrowane po wdrożeniu oprogramowania wewnętrznego iDRAC9 4.22.00.53 lub 4.32.10.00, sprawdź, czy przedni panel LED nie ma wady sprzętowej. Zaleca się rozpoczęcie od poniższych czynności rozwiązywania problemu:

  • Sprawdź, czy kabel płyty kontrolnej przedniej diody LED jest uszkodzony.
  • Ponownie podłącz kabel płyty kontrolnej przedniej diody LED, aby wyeliminować problem z połączeniem. 
  • Wymień płytę kontrolną przedniej diody LED, aby wyeliminować wadliwą diodę LED.
  • Wymień płytę główną, jeśli problemy nadal występują.

Affected Products

iDRAC9 - 3.0x Series, iDRAC9 - 3.1x Series, iDRAC9 - 3.2x Series, iDRAC9 - 3.3x Series, iDRAC9 - 3.4x Series, iDRAC9 - 4.xx Series, OEMR R340, OEMR R350, OEMR R360, OEMR R440

Products

OEMR R450, OEMR R540, OEMR R550, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR XL R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2 , OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR XL R760, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR T340, OEMR T350, OEMR T360, OEMR T440, OEMR T550, OEMR T560, OEMR T640, OEMR XL T640, OEMR XL R240, OEMR XL R340, OEMR XL R660xs, OEMR XL R6615, OEMR XL R6625, OEMR XL R760xs, OEMR XL R7615, OEMR XL R7625, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000181333
Article Type: Solution
Last Modified: 16 Jun 2025
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.