PowerEdge:iDRAC9:SWC5008:无法访问前 LED 面板,因为硬件状况

Summary: 本文介绍了一个影响运行 iDRAC9 的 PowerEdge 服务器的问题,SEL 中多次断言错误 SWC5008。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

运行 iDRAC9 的 Dell PowerEdge 服务器可能会在系统事件日志 (SEL) 中引用正面 LED 时出现过多SWC5008错误。SWC5008 事件也可能出现在 iDRAC9 生命周期日志中。出现这些错误的原因有多种。本文提供了有关 LED 控制器板的背景信息以及诊断错误迹象的方法。

Description:

SWC5008错误如图 1 和表 1 和 2 所示。
iDRAC9 控制面板关键系统运行状况示例

图 1:iDRAC9 控制面板关键系统运行状况示例



表 1:系统事件日志 (SEL) 示例

2020-06-02 07:08:15

2

Unable to access Front LED Panel because of a hardware error condition。

 

表 2:生命周期日志示例

2020-06-02 07:08:15

677

SWC5008

Unable to access Front LED Panel because of a hardware error condition。

 

 


Cause

前左侧 LED 控制面板由嵌入在 PowerEdge 服务器中的 iDRAC (BMC) 控制器监测和管理。定期状态查询每五秒进行一次,以验证前 LED 面板是否存在以及当前运行状况。iDRAC 还维护此控制器板上当前安装的固件。如果 iDRAC 固件中有适用的更新,iDRAC 将尝试在 iDRAC 启动周期内推送 LED 固件更新。在这两个过程中,iDRAC 使用 i2c 电路与此 LED 控制器板进行通信。在这些过程中,iDRAC 与左侧控制面板之间的通信超时会导致 SEL 和生命周期日志记录 SWC5008 错误事件。


前 LED 面板 PowerEdge R740XD

图 2:前置 LED 面板 PowerEdge R740XD

左侧控制面板 (LCP) 旨在支持开箱即用管理或系统运行状况概览。从系统正面看,它位于机箱的左侧。
在大多数 PowerEdge 服务器上,LCP 有两种形式:

  • Quick Sync 2 按钮或
  • 状态 LED 1 按钮 

在任一控制面板配置中,五个状态 LED 指示灯提供影响服务器的硬件故障的实时本机指示。有关这些 LED 指示灯的说明,请参见下面的图 3。

LED 运行状况状态指示灯 PowerEdge

图 3:LED 运行状况状态指示灯 PowerEdge
 

在正常服务器运行状况下,这五个 LED 指示灯熄灭。

在与这些 LED 指示灯对齐的其中一个子系统上检测到硬件故障时,背光将呈琥珀色常亮。

这些 LED 指示灯由 iDRAC (BMC) 控制器通过 i2c 电路上的通信进行控制。Quick Sync 和系统 ID 的指示灯不通过此相同的 i2c 电路进行管理,并且独立于状态 LED 指示灯运行。 

 


Resolution

Dell Technologies 建议升级到最新的 iDRAC9 固件以解决此问题。有关适用于您的系统的最新 iDRAC9 固件,请参阅 iDRAC9 版本和发行说明 。请注意,iDRAC9 固件可能因系统而异。

iDRAC9 固件版本 4.22.00.53 引入了从软锁定状态恢复前面板 LED 控制器的机制。从 4.32.10.00 开始的所有 iDRAC9 版本中都有这些更改。此版本中的更改不会掩蔽真正的前 LED 面板硬件故障。如果应用此固件后错误仍然存在,请继续对硬件进行故障处理。

如果在应用 iDRAC9 4.22.00.53 或 4.32.10.00 固件后继续记录到 SWC5008 事件,则应调查前 LED 面板是否存在可能的硬件故障。可以从以下故障处理步骤开始:

  • 检查前 LED 控制板线缆是否损坏。
  • 重新拔插前 LED 控制板线缆以查看是否存在连接问题。 
  • 更换出现 LED 故障的前 LED 控制板。
  • 对于任何持续存在的问题,请更换系统主板。

Affected Products

iDRAC9 - 3.0x Series, iDRAC9 - 3.1x Series, iDRAC9 - 3.2x Series, iDRAC9 - 3.3x Series, iDRAC9 - 3.4x Series, iDRAC9 - 4.xx Series, OEMR R340, OEMR R350, OEMR R360, OEMR R440

Products

OEMR R450, OEMR R540, OEMR R550, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR XL R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2 , OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR XL R760, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR T340, OEMR T350, OEMR T360, OEMR T440, OEMR T550, OEMR T560, OEMR T640, OEMR XL T640, OEMR XL R240, OEMR XL R340, OEMR XL R660xs, OEMR XL R6615, OEMR XL R6625, OEMR XL R760xs, OEMR XL R7615, OEMR XL R7625, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000181333
Article Type: Solution
Last Modified: 16 Jun 2025
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.