Dell Device Management Console (DDMC) User Blocked from Creating a Tenant Account

Summary: Information about a first-time user setting up a tenant account in Dell Device Management Console (DDMC).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When the new user onboards in DDMC, a screen informs them of an existing tenant with their Domain with an option to join. When selecting to join, a screen informs them an email was sent to their IT Admin to join the existing tenant.

The DDMC sends the email but does not display the target address of the email.

Cause

An account already exists using the Domain.

Resolution

Dell Device Management Console User

The DDMC user can ask their company IT Admins if a user has already set up an account in DDMC. If you are unable to locate the existing Admin, you can reach out to Dell for assistance.

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Affected Products

Dell Pro Smart Dock SD25, Dell Pro Thunderbolt 4 Smart Dock SD25TB4, Dell Pro Thunderbolt 5 Smart Dock SD25TB5, Dell Device Management Console
Article Properties
Article Number: 000347916
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  3
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