Connectrix MDS series: Module X reported warning due to Temperature sensor driver error

Summary: Connectrix MDS series: Module X reported warning due to Temperature sensor driver error in device 49 (device error 0xc310020b)

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Symptoms

Multiple sensors are down on one of the switch modules however the module is up.

`show module`
Mod  Ports  Module-Type                         Model              Status
---  -----  ----------------------------------- ------------------ ----------
x   48     1/2/4/8 Gbps FC Module              DS-X9248-96K9      ok

show logging log:
%MODULE-4-MOD_WARNING: Module X  reported warning due to Temperature sensor driver error in device 49 (device error 0xc310020b)

 ********* Exception info for module X ********
exception information --- exception instance 1 ----
Module Slot Number: X
Device Id         : 49
Device Name       : Temperature-sensor
Device Errorcode  : 0xc3103217
Device ID         : 49 (0x31)
Device Instance   : 03 (0x03)
Dev Type (HW/SW)  : 02 (0x02)
ErrNum (devInfo)  : 23 (0x17)
System Errorcode  : 0x40380022 TempSensor on this module failed (or inaccessible)
Error Type        : Minor error
PhyPortLayer      :
Port(s) Affected  :
DSAP              : 39 (0x27)
UUID              : 24 (0x18)
Time              : Fri May 19 20:38:38 2017
                    (Ticks: 591F900E jiffies)
 
Temperature:
--------------------------------------------------------------------
Module   Sensor        MajorThresh   MinorThres   CurTemp     Status
                       (Celsius)     (Celsius)    (Celsius)        
--------------------------------------------------------------------
11       Outlet1         n/a             n/a         n/a        Failure       
11       Outlet2         n/a             n/a         n/a        Failure       
11       Intake1         n/a             n/a         n/a        Failure  
 

Cause

Sensors failure on switch module

Resolution

  1. Reload the affected module. This is disruptive to traffic through the module.
  2. If the status persists post module reload, replace the module.
     

If the problem still exists, contact your Dell Technology Customer Service representative or the Dell Technology Customer Support Center for technical support and upload the switch logs to the service request, so that support staff can check them and provide you with feedback. Quote this solution ID 000052605. 

Affected Products

Connectrix MDS-Series Firmware

Products

Connectrix MDS-Series Firmware, Connectrix MDS-Series Hardware
Article Properties
Article Number: 000052605
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
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