Il backup RCT incrementale di Avamar Hyper-V ha esito negativo con l'errore "Failed to get RCT extents for the disk file" e/o "Reference point creation for Virtual machine failed"
Summary: Articolo della Knowledge Base (KB) che fornisce dettagli sugli hotfix che risolvono gli errori di backup Hyper-V Resilient Change Tracking (RCT) a causa di extent RCT.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Il backup RCT incrementale di Avamar Hyper-V non riesce per alcune macchine virtuali con l'errore "Failed to get RCT extents for the disk file"
Ecco un frammento del registro di backup:
Non è presente alcun messaggio di avviso o di errore nei registri applicazioni, sistema e Visualizzatore eventi di Hyper-V.
L'errore "Reference point creation for Virtual machine" viene visualizzato solo nei registri Avamar.
Ecco la parte pertinente di winclustersvc.log:
Ecco un frammento del registro di backup:
2019-07-08 23:44:41 avhypervvss Error <43426>: Checkpoint creation for Virtual machine '<VM_NAME>'<VM_GUID>' has failed and will be skipped from backup. For details, please check 'winclustersvc.log'. 2019-07-08 23:44:41 avhypervvss Error <43940>: Failed to get the RCT extents for Virtual machine '<VM_NAME>'<VM_GUID>' and will be skipped from backup. For details, please check 'winclustersvc.log'.Dal file winclustersvc.log (che si trova nella cartella VAR di Avamar sul nodo Hyper-V primario):
2019-07-08 23:44:35 winclustersvc ERROR<0000>: Failed to get RCT extents for the disk file C:\ClusterStorage\<VM_PATH_TO_VHDX>: Failed to get the disk information.Inoltre, il backup potrebbe non riuscire con l'errore riportato di seguito:
"Reference point creation for Virtual machine '<VM_NAME>'<VM_GUID>' has failed".Uno dei nodi del cluster ospita le VM interessate.
Non è presente alcun messaggio di avviso o di errore nei registri applicazioni, sistema e Visualizzatore eventi di Hyper-V.
L'errore "Reference point creation for Virtual machine" viene visualizzato solo nei registri Avamar.
Ecco la parte pertinente di winclustersvc.log:
2019-06-25 18:19:41 winclustersvc DEBUG<0000>: Affected VM Path is \\<Hyperv_Node>\root\virtualization\v2:Msvm_ComputerSystem.CreationClassName="Msvm_ComputerSystem",Name="<.....>" 2019-06-25 18:19:41 winclustersvc DEBUG<0000>: ===> ValidateJobOutput 2019-06-25 18:27:09 winclustersvc DEBUG<0000>: <=== ValidateJobOutput 2019-06-25 18:27:09 winclustersvc ERROR<0000>: Exception in validateTargetMergeStatus: Not found . 2019-06-25 18:27:10 winclustersvc ERROR<0000>: Exception in validateTargetMergeStatus: Not found . 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ResilientChangeTrackingIdentifiers rctid :rctX:917dbfe9:0da5:4fda:8d9f:34cdc6cf85b8:00000002 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: VirtualDiskIdentifiers vmid :Microsoft:<................> 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: Affected VM Path is \\<Hyperv_Node>\root\virtualization\v2:Msvm_ComputerSystem.CreationClassName="Msvm_ComputerSystem",Name="<......>" 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ===> ValidateJobOutput 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: <=== ValidateJobOutput 2019-06-25 18:27:10 winclustersvc INFO<0000>: Exception in reference point creation for vm group 'AvamarBackup_<........>' : Not found 2019-06-25 18:27:10 winclustersvc INFO<0000>: Reference point conversion failed for vm <VM_NAME>.. . . 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ===> SerializeHypervVMList. 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: <=== SerializeHypervVMList. 2019-06-25 18:27:10 winclustersvc INFO<0000>: ----------------------End [EMC Avamar Plug-in Service for Windows] log ------------------- 2019-06-25 20:15:08 winclustersvc INFO<0000>: Cleaning up checkpoint created on group AvamarBackup_<........> 2019-06-25 20:15:08 winclustersvc WARN<0000>: Failed to execute DestroySnapshot method: The method call failed.. 2019-06-25 20:15:08 winclustersvc INFO<0000>: Cleaning up checkpoint created on group AvamarBackup_<........> 2019-06-25 20:15:08 winclustersvc WARN<0000>: Failed to execute DestroySnapshot method: The method call failed.. 2019-06-25 21:31:32 winclustersvc INFO<0000>: Creating an alternate Log file : C:\ClusterStorage\<...>\var-share\temp_log.log 2019-06-25 21:31:32 winclustersvc INFO<0000>: Debug output enabled from Plug-in.Ogni volta che il backup viene forzato a essere completo e alla fine non riesce a causa di un "errore del punto di riferimento", la macchina virtuale (VM) viene quindi esclusa.
Cause
Il plug-in Hyper-V VSS utilizzava originariamente lo spazio dei nomi Hyper-V nelle chiamate WMI per ottenere gli extent RCT. Per i nuovi hotfix, il codice è stato modificato per fare riferimento al namespace del cluster.
Resolution
Gli hotfix cumulativi di Avamar Hyper-V sono necessari per le versioni precedenti del plug-in. Incorporano le più recenti modifiche al codice per Resilient Change Tracking (RCT) per miglioramenti sia di backup che di ripristino.
Elenco degli hotfix cumulativi più recenti del plug-in Hyper-V:
Per scaricare gli hotfix, vedere la sezione "Ricerca di un hotfix conoscendo il numero HF" del seguente articolo: Per istruzioni sull'applicazione degli hotfix o sull'upgrade alla versione più recente di Avamar, consultare il seguente articolo della Knowledge Base di DELL:
Avamar: Plug-in Hyper-V VSS: configurazione e installazione degli hotfix cumulativi più recenti per la versione 19.4 e successive
Elenco degli hotfix cumulativi più recenti del plug-in Hyper-V:
- Plug-in Avamar versione 19.4.100-124 HF 337285
- Avamar Plugin versione 19.7.100-82 HF 337450
- Plug-in Avamar versione 19.8.100-83 HF 337654
Per scaricare gli hotfix, vedere la sezione "Ricerca di un hotfix conoscendo il numero HF" del seguente articolo: Per istruzioni sull'applicazione degli hotfix o sull'upgrade alla versione più recente di Avamar, consultare il seguente articolo della Knowledge Base di DELL:
Avamar: Plug-in Hyper-V VSS: configurazione e installazione degli hotfix cumulativi più recenti per la versione 19.4 e successive
Affected Products
AvamarArticle Properties
Article Number: 000080002
Article Type: Solution
Last Modified: 07 Oct 2024
Version: 9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.