Dell Unity: La modalità di replica cambia da sincrona a asincrona dopo l'aggiornamento del codice alla versione 5.2 (correggibile da Dell)
Summary: La modalità di replica potrebbe essere modificata dalla sincronizzazione alla modalità asincrona dopo l'aggiornamento al codice 5.2. Ciò comporta un errore di convalida della connessione di replica e un impatto sulle operazioni correlate alla replica, come pausa/ripresa/failover/failback. ...
Symptoms
Le sessioni di replica sincrona non riprenderanno.
Le connessioni di replica sull'origine mostreranno lo stato "Updated Needed".
Il tipo di connessione viene modificato da sincrona a asincrona, come mostrato di seguito dall'output uemcli:
uemcli -d -u service -p /remote/sys show -detail
2. ID = RS_1 <<< RS è l'acronimo di Remote System. In genere RS_0 è il sistema locale, RS_1 è il primo sistema remoto configurato su Unity locale e RS_2 è il secondo sistema remoto.
Nome = XXX-Indirizzo Unity
= 10.xxx.xxx.xxx
Indirizzo di gestione alternativo = modello 10.xxx.xxx.xxx
= numero di serie Unity 480F
= CKM00XXXXXXXXX
tipo di connessione = asincrona <<<<<<<<<<<< la modalità era sincronizzata prima dell'aggiornamento
del codice Interfacce di origine = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
Interfacce locali = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
Remote interfaces = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
Stato operativo = Update Needed (0x8406)
Health state = Minor failure (15)
Health details = "Update the remote system connection to pick up the latest interface changes on the local and remote systems. (https://10.xxx.xxx.xxx/help/webhelp/en_US/index.html?#unity_t_configure_replication_connections.html)"
Porte FC sincrone = spb_iom_1_fc0, spa_iom_1_fc0
pianificazioni della larghezza di banda = utilizza la larghezza di banda
disponibile Larghezza di banda corrente = utilizza la larghezza di banda
disponibile Se il cliente tenta di "convalidare e aggiornare" la connessione, l'operazione ha esito negativo con errore "No remote interfaces received from the remote system".
EMCsystemlog:
"2022-06-15T22:56:51.960Z" "XXX-Unity_spa@CKM00XXXXXXXXX" "Neo_CEM" "26592" "local/admin" "ERROR" "14:610012" :: "User local/admin failed to validate remote system connections RS_1." :: Category=Audit Component=ReplicationPlugin TimeZone=UTC
cemtracer_dataprotection.log:
15 Giu 2022 22:56:51 - [DataProtectionStorageModel] INFO - {0:271532:843299283}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ .. /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1315] Aggiornamento del nome del sistema remoto in: XXX-Unity
15 giu 2022 22:56:51 - [DataProtectionStorageModel] ERROR - {0:271533:341483364}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ .. /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1334] Nessuna interfaccia remota ricevuta dal sistema
remoto 15 giu 2022 22:56:1 51 - [DataProtectionStorageModel] ERROR - {0:271533:343407806}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ .. /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1425] Eccezione rilevata: Eccezione StorageModello [105906509]: Impossibile ottenere l'elenco delle interfacce dal sistema remoto.
Cause
I tecnici hanno confermato che la causa del cambiamento del tipo di connessione da "sync" a "async" è una combinazione dei due comportamenti noti seguenti nel codice corrente (5.2):
1. A partire dalla versione 5.1, lo stato operativo della connessione di replica viene visualizzato come "Update Needed (0x8406)" dopo il riavvio dell'SP (aggiornamento NDU), che è stato risolto in Unity OE versione 5.2.1.0.5.013.
2. Nella versione 5.2 corrente, la modifica della connessione di replica con l'input del nome utente remoto e della password (senza il tipo di connessione specificato in modo esplicito) dalla GUI o uemcli terminerà con il tipo di connessione di replica modificato in "async" (da "sync" o "both"), che verrà corretto in una versione futura.
Finora il problema (la modalità di replica passa dalla sincronizzazione alla modalità asincrona) si verifica solo sul lato di origine di Unity. Se si riscontra lo stesso problema con Unity DR, eseguire l'escalation del caso a L2 e coinvolgere EE per approfondire il problema. La soluzione alternativa disponibile nella sezione Risoluzione di questo articolo della Knowledge Base di Dell può comunque essere utilizzata.
Resolution
La correzione è disponibile nel sistema operativo 5.2.1.0.5.013 (5.2 SP1)
Soluzione:
Soluzione alternativa per il problema di mancata corrispondenza del tipo di connessione di replica tra due lati dopo l'aggiornamento a 5.2.
Un. Per la connessione di replica con il tipo "sync" (la mancata corrispondenza del sito A è "asincrona" e il sito B è "sync")
1> Modifica il tipo "sync" in "both" dal sito B. (ora due siti sono di tipo "entrambi")
2> Modifica il tipo "both" in "sync" dal sito B (o dal sito A).
B. Per la connessione di replica con il tipo "both" (la mancata corrispondenza del sito A è "asincrona" e il sito B è "entrambi")
1> Modificare il tipo "both" in "async" dal sito B. (ora due siti sono di tipo "async")
2> Modificare il tipo "async" in "entrambi" dal sito B (o dal sito A).
Nota:
i comandi uemcli riportati di seguito possono essere utilizzati per modificare il tipo di connessione su entrambi o sulla sincronizzazione. Il campo RS_x in -id è l'ID del sistema remoto che ha un problema.
Passare a entrambi:
uemcli -u admin -p XXXXXX /remote/sys -id RS_1 set -connectionType bothPassa alla sincronizzazione:
uemcli -u admin -p XXXXXX /remote/sys -id RS_1 set -connectionType sync
Sintassi dei comandi:
[Set]
/remote/sys -id set [ -addr ] [ -dstUsername { -dstPassword | -dstPasswordSecure } ] [ -connectionType { sync | async | both } ] [ -bandwidthSchedules ]
- Una volta che la modalità su entrambe le estremità viene modificata per la sincronizzazione, convalidare la connessione su entrambe le estremità uno alla volta.