Dell Unity. Режим репликации меняется с синхронной на асинхронную после обновления кода до версии 5.2 (исправляется Dell)
Summary: После модернизации до версии 5.2 режим репликации может измениться с синхронной на асинхронную. Это приводит к сбою проверки подключения для репликации и влияет на операции, связанные с репликацией, такие как приостановка/возобновление/переключение при отказе/восстановление после сбоя. ...
Symptoms
Сессии синхронной репликации не возобновлятся.
Подключения репликации в источнике будут отображать состояние «Обновлено необходимо».
Тип подключения меняется с синхронизации на асинхронный, как показано ниже в выходных данных uemcli:
uemcli -d -u service -p /remote/sys show -detail
2. Идентификатор = RS_1 <<< RS означает «удаленная система». Обычно RS_0 является локальной системой, RS_1 первой удаленной системой, которая настраивается в локальной системе Unity, а RS_2 — второй удаленной системой.
Имя = XXX-Unity
Address = 10.xxx.xxx.xxx
Alternate Management Address = 10.xxx.xxx.xxx
Model = Серийный номер Unity 480F
= CKM00XXXXXXXXX
Тип подключения = async <<<<<<<<<<<< режим
был синхронизирован до обновления кода Исходные интерфейсы = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
Локальные интерфейсы = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
Remote interfaces = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
Operational status = Update Needed (0x8406)
Health state = Minor failure (15)
Health details = "Update the remote system connection to pick up the latest interface changes on the local and remote systems. (https://10.xxx.xxx.xxx/help/webhelp/en_US/index.html?#unity_t_configure_replication_connections.html)»
Синхронные порты FC = spb_iom_1_fc0, расписания пропускной способности spa_iom_1_fc0
=
использует доступную пропускную способность Текущая полоса пропускания =
использует доступную пропускную способность Если заказчик пытается «проверить и обновить» подключение, операция завершается сбоем с ошибкой «No remote interfaces received from the remote system».
EMCsystemlog:
"2022-06-15T22:56:51.960Z" "XXX-Unity_spa@CKM00XXXXXXXXX" "Neo_CEM" "26592" "local/admin" "ERROR" "14:610012" :: «Пользователю local/admin не удалось проверить подключения к удаленной системе RS_1». :: Category=Audit Component=ReplicationPlugin TimeZone=UTC
cemtracer_dataprotection.log:
15 июня 2022 г. 22:56:51 - [DataProtectionStorageModel] INFO - {0:271532:843299283}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ . /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1315] Обновление имени удаленной системы до: XXX-Unity
15 июня 2022 г., 22:56:51 - [DataProtectionStorageModel] ERROR - {0:271533:341483364}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ . /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1334] Удаленные
интерфейсы не получены от удаленной системы 15 июня 2022 г. 22:56: 51 - [DataProtectionStorageModel] ERROR - {0:271533:343407806}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ . /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1425] Caught exception: Исключение StorageModel [105906509]: Не удалось получить список интерфейсов из удаленной системы.
Cause
Технический отдел подтвердил, что причина изменения типа подключения с «sync» на «async» представляет собой сочетание следующих двух известных поведений в текущем коде (5.2):
1. Начиная с версии 5.1 рабочее состояние подключения репликации будет отображаться как «Update Needed (0x8406)» после перезагрузки процессора СХД (модернизация NDU), это исправлено в unity OE версии 5.2.1.0.5.013.
2. В текущем выпуске 5.2 изменение подключения репликации с помощью ввода имени удаленного пользователя и пароля (без явного типа подключения) из графического интерфейса пользователя или uemcli приведет к изменению типа подключения репликации на «асинхронный» (с «sync» или «both»). Исправление планируется в будущей версии.
На данный момент проблема (изменение режима репликации с синхронной на асинхронную) наблюдается только на исходной стороне Unity. Если в системе Unity для аварийного восстановления возникает та же проблема, передайте заявку на уровень L2 и привлеките EE для дальнейшего изучения проблемы. Временное решение в разделе «Способ устранения» данной статьи базы знаний Dell по-прежнему можно использовать.
Resolution
Исправление доступно в ОС 5.2.1.0.5.013 (5.2 SP1)
Решение:
Временное решение проблемы несоответствия подключений репликации между двумя сторонами после модернизации до версии 5.2.
a. Для подключения репликации с помощью типа «sync» (несоответствие площадки A — «async», а площадка B — «sync»)
1> Измените тип «sync» на «both» с площадки B. (Теперь две площадки являются «обоими» типами)
2> Измените «both» на «sync» с площадки B (или площадки A).
B. Для подключения репликации с использованием обоих типов (несоответствие площадки A — «async», а площадка B — «both»)1>
Измените «both» type на «async» с площадки B. (Теперь две площадки являются типами «async»)
2> Измените тип «async» на «both» с площадки B (или площадки A).
Примечание.Для
изменения типа подключения на оба или на синхронный режим можно использовать приведенные ниже команды uemcli. Поле RS_x -id — это идентификатор удаленной системы, в котором возникла проблема.
Измените на оба:
uemcli -u admin -p XXXXXX /remote/sys -id RS_1 set -connectionType bothИзменение синхронизации:
uemcli -u admin -p XXXXXX /remote/sys -id RS_1 set -connectionType sync
Синтаксис команды:
[Set]
/remote/sys -id set [ -addr ] [ -dstUsername { -dstPassword | -dstPasswordSecure } ] [ -connectionType { sync | async | both } ] [ -bandwidthSchedules ]
- После изменения режима на обоих концах для синхронизации проверьте подключение на обоих концах по одному.