Dell Unity: Replicatiemodus verandert van sync naar async na code-upgrade naar 5.2 (op te lossen door Dell)

Summary: De replicatiemodus kan worden gewijzigd van sync naar async na een upgrade naar code 5.2. Dit leidt tot validatiefouten bij replicatieverbindingen en heeft gevolgen voor replicatie-gerelateerde bewerkingen zoals pause/resume/failover/failback. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Na een code-upgrade naar 5.2 kunnen de volgende problemen optreden:
synchronisatiereplicatiesessies worden niet hervat.

Replicatieverbindingen op de bron geven de status 'Updated Needed' weer.

Het verbindingstype wordt gewijzigd van sync naar async, zoals hieronder weergegeven in uemcli-uitvoer:
 
uemcli -d  -u service -p  /remote/sys show -detail


2:    ID = RS_1 <<< RS staat voor Remote System. Meestal is RS_0 het lokale systeem, is RS_1 het eerste externe systeem dat is geconfigureerd op de lokale Unity en is RS_2 het tweede externe systeem. 
      Name = XXX-Unity
Address = 10.xxx.xxx.xxx
Alternate Management Address = 10.xxx.xxx.xxx
Model = Unity 480F
Serial Number = CKM00XXXXXXXXX
Connection type = async <<<<<<<<<<<< the mode was sync before code upgrade
Source interfaces = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
      Lokale interfaces = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
externe interfaces = 10.xxx.xxx.xxx, 10.xxx.xxx.xxx
operationele status = Update Needed (0x8406)
Health state = Kleine fout (15)
Statusdetails = "Update the remote system connection to pick up the latest interface changes on the local and remote systems. (https://10.xxx.xxx.xxx/help/webhelp/en_US/index.html?#unity_t_configure_replication_connections.html)"
Synchrone FC-poorten = spb_iom_1_fc0, spa_iom_1_fc0
Bandbreedteschema's = maakt gebruik van beschikbare bandbreedte
Huidige bandbreedte = gebruikt beschikbare bandbreedte

Als de klant de verbinding probeert te 'valideren en bij te werken', mislukt de bewerking met de foutmelding "No remote interfaces received from the remote system".

EMCsystemlog:

"2022-06-15T22:56:51.960Z" "XXX-Unity_spa@CKM00XXXXXXXXX" "Neo_CEM" "26592" "local/admin" "ERROR" "14:610012" :: "User local/admin failed to validate remote system connections RS_1." :: Category=Audit Component=ReplicationPlugin TimeZone=UTC

cemtracer_dataprotection.log: 
15 jun 2022 22:56:51 - [DataProtectionStorageModel] INFO - {0:271532:843299283}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ .. /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1315] De naam van het externe systeem bijwerken naar: XXX-Unity
15 jun 2022 22:56:51 - [DataProtectionStorageModel] ERROR - {0:271533:341483364}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ .. /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1334] Geen externe interfaces ontvangen van het externe systeem
15 jun 2022 22:56:51 - FOUT [DataProtectionStorageModel] - {0:271533:343407806}[26592|30974|d53ffb40][refreshLocalExternalSystemInterconnects @ .. /.. /.. /components/providers/osls/common/DataProtection/StorageModel/impl/StorageResourceSubsystemImpl.cpp:1425] Een uitzondering: StorageModel-uitzondering [105906509]: Kan de lijst met interfaces van het externe systeem niet ophalen.

Cause

Engineering heeft bevestigd dat de oorzaak van de wijziging van het verbindingstype van 'sync' naar 'async' een combinatie is van de volgende twee bekende gedrag in de huidige code (5.2):

1. Sinds 5.1 wordt de operationele status van de replicatieverbinding weergegeven als "Update Needed (0x8406)" na sp opnieuw opstarten (NDU-upgrade). Dit is opgelost in Unity OE versie 5.2.1.0.5.013.

2. In de huidige versie van 5.2 zal het wijzigen van de replicatieverbinding met externe gebruikersnaam en wachtwoordinvoer (zonder verbindingstype expliciet gespecificeerd) uit de GUI of uemcli eindigen in het replicatieverbindingstype dat is gewijzigd in 'async' (van 'sync' of 'beide'). Dit wordt naar verwachting opgelost in een toekomstige versie. 

Tot nu toe wordt het probleem (replicatiemodus verandert van sync naar async) alleen waargenomen aan de bronzijde van de Unity. Als u ziet dat een DR Unity hetzelfde probleem heeft, escaleer dan de case naar L2 en neem contact op met EE om het probleem verder te onderzoeken. De tijdelijke oplossing in het gedeelte Oplossing van dit Dell Knowledge Base-artikel kan nog steeds worden gebruikt. 

Resolution

Resolutie:
De oplossing is beschikbaar in OS 5.2.1.0.5.013 (5.2 SP1)

Oplossing:
Tijdelijke oplossing voor een probleem met een niet-overeenkomende replicatieverbinding tussen twee zijden na een upgrade naar 5.2.
 
A. Voor replicatieverbinding met het type 'sync' (mismatch van site A is 'async' en site B is 'sync')
1> Wijzig 'sync'-type in 'both' van site B. (Nu zijn twee sites 'both'-type)
2> Wijzig 'both' type in 'sync' van site B (of site A).

B. Voor replicatieverbinding met het type 'both' (mismatch van site A is 'async' en site B is 'both')
1> Wijzig het type 'both' in 'async' van site B. (nu zijn twee sites 'async'-type)
2> Wijzig 'async'-type in 'both' van site B (of site A).


Opmerking:
Onderstaande uemcli-opdrachten kunnen worden gebruikt om het verbindingstype te wijzigen in beide of sync. De RS_x in het veld -id is de id van het externe systeem dat een probleem ondervindt. 

Wijzig naar beide: 
uemcli -u admin -p XXXXXX /remote/sys  -id RS_1 set -connectionType both 
Wijzigen in synchronisatie:
uemcli -u admin -p XXXXXX /remote/sys  -id RS_1 set -connectionType sync
 
Opdrachtsyntaxis: 
 
  [Set]
  /remote/sys -id  set [ -addr  ] [ -dstUsername  { -dstPassword  | -dstPasswordSecure } ] [ -connectionType { sync | async | both } ] [ -bandwidthSchedules  ]

- Zodra de modus aan beide uiteinden is gewijzigd in sync, valideer dan de verbinding aan beide uiteinden één voor één.

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000200659
Article Type: Solution
Last Modified: 11 May 2023
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.