NetWorker : Échec de la sauvegarde avec : Impossible de créer un canal de session avec nsrexecd sur le nom du client hôte pour exécuter la commande « savefs »....
Summary: La sauvegarde échoue avec l’erreur « Impossible de créer un canal de session avec nsrexecd sur l’hôte nom_client » pour exécuter la commande « savefs -s server-name -c client-name -g »
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
La sauvegarde NetWorker basée sur le client échoue avec :
Unable to create session channel with nsrexecd on host client-name to execute command 'savefs -s server-name -c client-name'
Cause
Il existe un problème de communication entre le serveur et le client.
Resolution
Étapes initiales :
- Vérifiez que nsrexecd est en cours d’exécution sur le client.
-
Linux: ps -ef | grep nsrexecd Windows: tasklist | findstr nsrexecd
-
- Si les services client ne sont pas en cours d’exécution, démarrez-les et surveillez les éventuels problèmes de service :
-
Linux: systemctl start networker Windows: net start nsrexecd
-
- Les problèmes de démarrage du service peuvent être surveillés dans le fichier daemon.raw du client :
-
Linux: /nsr/logs/daemon.raw Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
- Mode d’emploi nsr_render_log : NetWorker : utilisation de nsr_render_log
- Activation du rendu des fichiers log en temps réel : NetWorker : Afficher automatiquement daemon.raw daemon.log en temps réel
-
- Vérifiez que la résolution de noms fonctionne correctement à partir du NetWorker Server et du client à l’aide de nslookup. Le FQDN, le nom abrégé et l’adresse IP doivent tous être renvoyés correctement.
Dépannage de la connectivité :
- Vérifiez que nsradmin peut se connecter du serveur au client et vice versa :
nsradmin -p nsrexecd -s client-nameOù 'client-name' est le nom d’hôte du client tel que défini dans la configuration NetWorker.
- Vérifiez la plage de ports sur le serveur et le client avec nsrports pour confirmer qu’ils correspondent. La plage de ports de service par défaut utilisée par NetWorker est 7937-9936.
- Sur le NetWorker Server, vérifiez quels ports/processus sont visibles depuis le client :
nsrrprcinfo -p client-nameOù 'client-name' est le nom d’hôte du client tel que défini dans la configuration NetWorker.
PS C:\Windows\system32> nsrrpcinfo -p winsrvr2k16.emclab.local
PROGRAM VERSION PROTOCOL PORT SERVICE
100000 2 tcp 7938 nsrportmapper Port Mapper
100000 2 udp 7938 nsrportmapper Port Mapper
390436 1 tcp 8655 nsrexecd GSS Authentication
390435 1 tcp 9220 nsrexecd Resource Mirror
390113 1 tcp 7937 nsrexecd Remote Execution
390440 1 tcp 9500 nsrexecd_nsrfa Remote File Access
Les ports sont attribués dynamiquement à partir de la plage de ports configurée.
- Vérifiez si un pare-feu logiciel est en cours d’exécution sur le client et, le cas échéant, que la plage de ports inclut les ports NetWorker :
- Linux :
firewall-cmd --list-all
Une configuration classique, avec les ports NetWorker par défaut, est la suivante :
- Linux :
# firewall-cmd --list-all
public (active)
target: %%REJECT%%
icmp-block-inversion: no
interfaces: ens3
sources:
services:
ports: 7937-9936/tcp
protocols:
forward: no
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:
rule family="ipv4" source ipset="jump-servers" service name="ssh" accept
Toutefois, une configuration de pare-feu mal configurée peut ressembler à :
# firewall-cmd --list-all
public (active)
target: %%REJECT%%
icmp-block-inversion: yes
interfaces: ens3
sources:
services:
ports: 7936-7996/tcp
protocols:
forward: no
masquerade: no
forward-ports:
source-ports:
icmp-blocks: echo-reply echo-request
rich rules:
rule family="ipv4" source ipset="jump-servers" service name="ssh" accept
Windows :
Ouvrez le pare-feu Windows Defender avec la sécurité avancée et passez en revue les règles entrantes et sortantes . Recherchez les règles qui bloquent ou restreignent la plage de ports NetWorker (comme indiqué avec nsrports). La colonne Local Port affiche la plage de ports à laquelle la règle est appliquée.
Remarque : L’administrateur du système d’exploitation doit être chargé de vérifier tous les paramètres ou logiciels supplémentaires du système d’exploitation susceptibles de bloquer la communication. Si aucune configuration au niveau du système d’exploitation n’est trouvée, la communication peut être bloquée par un périphérique réseau. L’administrateur réseau doit également passer en revue toutes les configurations réseau susceptibles de bloquer la communication.
- Il est recommandé d’utiliser la plage de ports par défaut (7937-9936) lorsque cela est possible. La plage de ports peut être définie à l’aide de la commande nsrports :
nsrports -S 7937-9936
Affected Products
NetWorker Family, NetWorkerArticle Properties
Article Number: 000207523
Article Type: Solution
Last Modified: 20 Apr 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.