Impossibile decrittografare: BAD_DATA errore viene visualizzato nell'interfaccia utente di NMC dopo una migrazione del server NetWorker

Summary: Impossibile decrittografare: BAD_DATA errore può verificarsi quando si verifica un problema con l'archivio protetto, sia a causa di un danneggiamento nel lockbox sia quando il server NetWorker è stato migrato, spostato o reinstallato e l'archivio protetto non è stato copiato su /restore. L'archivio protetto corrente non dispone delle password memorizzate che corrispondono all'utente/password in nsrdb, quindi l'errore BAD_DATA. ...

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Symptoms

  • Il server NetWorker è stato migrato su un nuovo hardware
  • è stato eseguito nsrdr per ripristinare la configurazione di NetWorker
  • la password è stata assegnata ai campi di alcune risorse di NetWorker
  • Nell'interfaccia utente di NMC, il pop-up viene visualizzato quando si clicca su alcune risorse di NetWorker.

PNG bad_data


Cause

"Unable to decrypt: BAD_DATA" può verificarsi quando si verifica un problema con l'archivio protetto, a causa di un danneggiamento nel lockbox o quando il server NetWorker è stato migrato, spostato o reinstallato e l'archivio protetto non è stato copiato su /restore. L'archivio protetto corrente non dispone delle password memorizzate che corrispondono all'utente/password in nsrdb, quindi il BAD_DATA errore.

Resolution

Per risolvere il pop-up di errore BAD_DATA da NMC, sostituire l'archivio protetto corrente con quello originale del server NetWorker prima di una migrazione o di nsrdr. Su un server Linux Networker, esportare il lockbox originale utilizzando il comando nsr_prep_lb . Fare riferimento alla NetWorker Security Configuration Guide per istruzioni su come esportare l'archivio protetto.

Se non è possibile importare l'archivio protetto originale, reimpostare tutti i campi della password nelle risorse di NetWorker in modo che siano vuoti.

Come reimpostare le password in nsrdb

1) Creare un file di input con i nomi delle password che devono essere cancellati in nsrdb.  Creare un file denominato "pass.txt" contenente le seguenti righe:

password di aggiornamento: ;
y
password di gestione degli aggiornamenti: ;
y
aggiornare la password di gestione NAS: ;
y
aggiornare la password di accesso al file NAS: ;
y
aggiornare la chiave di autenticazione: ;
y
aggiornare la password utente di VMWS: ;
y
aggiorna la password EBR: ;
y
aggiorna la password dei servizi REST: ;
y
aggiorna la password di vCenter: ;
y
aggiornare la chiave di privacy: ;
y
aggiornare la frase pass datazone: ;
y

2) Arrestare i servizi NetWorker.

Su Linux: systemctl stop networker
In Windows:  Arrestare NetWorker Backup and Recover Server Service e NetWorker Remote Exec Service

3) Creare una copia di nsrdb. Chiamare questo file nsrdb.beforepassclean.

4) Eseguire il comando nsradmin con il file di input pass.txt.

Su LInux: 

# nsradmin -i pass.txt -d /nsr/res/nsrdb

In Windows:C:

> nsradmin -i pass.txt -d "C:\Program Files\EMC Networker\nsr\res\nsrdb"

5) Creare un'altra copia del nsrdb modificato. Chiama questo nsrdb_passwordblank. Rinominare la cartella dbg in nsrdb, se presente.

6) In un ambiente Windows, seguire la procedura Modificare la proprietà di nsrdb di seguito prima di procedere al passaggio 7.

7) Avviare il servizio NetWorker.

8) Avviare NMC. A questo punto, immettere nuovamente la password assegnata alle risorse di NetWorker.

Modifica della proprietà di nsrdb

In un server Windows NetWorker, la proprietà dei file nsrdb modificati verrà modificata da Amministratori (gruppo) a qualsiasi utente attualmente connesso. In questo modo, dopo il riavvio, NetWorker danneggia le voci modificate, spostando questi file nella cartella dbg. Per questo motivo, prima di avviare i servizi NetWorker su Windows, impostare le autorizzazioni di tutti i file in nsrdb in modo che siano di proprietà degli amministratori del gruppo (non dell'utente, ma del gruppo). 

Cliccare su "C:\Program Files\EMC Networker\nsr\res\nsrdb" in Esplora file e impostare la proprietà per tutti i file e gli object figlio su Amministratori.

a) In Esplora file, cliccare con il pulsante destro del mouse sulla cartella
C:\Program Files\EMC NetWorker\nsr\res\nsrdb b) Selezionare proprietà.
c) Cliccare sulla scheda
"Sicurezza".d) Cliccare su "Avanzate"
e) In Owner, cliccare su "Change"


advanced.PNG
f) Nella casella "Enter the object name to select", digitare: Gli amministratori, quindi cliccare su "Controlla nomi". A volte è necessario utilizzare il nome del computer, ad esempio AMER\Administrators.

g) Cliccare su OK




amministratori.PNG

h) Inserire un segno di spunta in "Replace all child object permission entries..."   e "Replace owner on subcontainers and objects".

i) Cliccare su "Apply", quindi su "Yes" per la casella "Do you wish to continue?".

j) Cliccare su "OK"

sostituito.PNG




Affected Products

NetWorker
Article Properties
Article Number: 000214570
Article Type: Solution
Last Modified: 29 Apr 2025
Version:  6
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