No se puede descifrar: BAD_DATA error aparece en la interfaz de usuario de NMC después de una migración del servidor de NetWorker

Summary: No se puede descifrar: BAD_DATA error puede ocurrir cuando hay un problema con la caja de seguridad, ya sea debido a daños en la caja de seguridad o cuando se migró, movió o reinstaló el servidor de NetWorker y la caja de seguridad no se copió/restauró. La caja de seguridad actual no tiene las contraseñas almacenadas que coincidan con el usuario o las contraseñas en nsrdb, por lo tanto, el BAD_DATA error. ...

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Symptoms

  • El servidor de NetWorker se migró a un nuevo hardware
  • nsrdr se realizó para recuperar la configuración de NetWorker
  • contraseña se asignó a campos de algunos recursos de NetWorker
  • En la interfaz del usuario de NMC, se muestra la ventana emergente cuando se hace clic en algunos de los recursos de NetWorker.

bad_data.PNG


Cause

"No se puede descifrar: BAD_DATA" se puede producir cuando hay un problema con la caja de seguridad, ya sea debido a daños en la caja de seguridad o cuando se migró, movió o reinstaló el servidor de NetWorker y la caja de seguridad no se copió o se restauró. La caja de seguridad actual no tiene las contraseñas almacenadas que coincidan con el usuario/contraseña en nsrdb, por lo tanto, el BAD_DATA error.

Resolution

Para resolver la BAD_DATA ventana emergente de error de NMC, reemplace la caja de seguridad actual con la caja de seguridad original del servidor de NetWorker antes de una migración o un nsrdr. En un servidor de Linux Networker, exporte la caja de seguridad original mediante el comando nsr_prep_lb . Consulte la Guía de configuración de seguridad de NetWorker para obtener instrucciones sobre cómo exportar la caja de seguridad.

Si no es posible importar el lockbox original, restablezca todos los campos de contraseña en los recursos de NetWorker a blanco.

Cómo restablecer las contraseñas en nsrdb

1) Cree un archivo de entrada con los nombres de las contraseñas que se deben borrar en nsrdb.  Cree un archivo llamado "pass.txt" que contenga las siguientes líneas:

actualizar contraseña: ;
y update management password (Contraseña de administración de actualizaciones de y
): ;
y
actualizar contraseña de administración de NAS: ;
y
actualizar contraseña de acceso a archivos NAS: ;
y
update Clave de autenticación: ;
y
actualizar contraseña de usuario de VMWS: ;
y
actualizar contraseña de EBR: ;
y
actualizar contraseña de servicios REST: ;
y
actualizar contraseña de vCenter: ;
y
update Clave de privacidad: ;
frase de contraseña y
update datazone: ;
y

2) Detenga los servicios de NetWorker.

En Linux: systemctl stop networker
on Windows:  Detenga el servicio del servidor de respaldo y recuperación de NetWorker y el servicio

NetWorker Remote Exec 3) Haga una copia de nsrdb. Llame a esto nsrdb.beforepassclean.

4) Ejecute el comando nsradmin con el archivo de entrada pass.txt.

En LInux: 

# nsradmin -i pass.txt -d /nsr/res/nsrdb

En Windows:C:

> nsradmin -i pass.txt -d "C:\Program Files\EMC Networker\nsr\res\nsrdb"

5) Realice otra copia del nsrdb modificado. Llame a esta nsrdb_passwordblank. Cambie el nombre de la carpeta dbg en nsrdb, si la hay.

6) En un entorno de Windows, siga el procedimiento Cambiar la propiedad de nsrdb a continuación antes de continuar con el paso 7.

7) Inicie el servicio de NetWorker.

8) Inicie NMC. En este punto, vuelva a ingresar la contraseña que se asignó a los recursos de NetWorker.

Cambiar la propiedad de nsrdb

En un servidor NetWorker de Windows, la propiedad de los archivos nsrdb modificados se cambiará de administradores (el grupo) a cualquier usuario que haya iniciado sesión actualmente como. Esto hará que NetWorker dañe las entradas modificadas después del reinicio y mueva estos archivos a la carpeta dbg. Por este motivo, antes de iniciar los servicios de NetWorker en Windows, configure los permisos de todos los archivos en nsrdb para que sean propiedad de los administradores del grupo (no el usuario, sino el grupo). 

Haga clic en "C:\Program Files\EMC Networker\nsr\res\nsrdb" en el explorador de archivos y establezca la propiedad de todos los archivos y objetos secundarios en administradores.

a) En el explorador de archivos, haga clic con el botón secundario en la carpeta
C:\Program Files\EMC NetWorker\nsr\res\nsrdb b) Seleccione las propiedades.
c) Haga clic en la pestaña "Seguridad".
d) Haga clic en "Avanzado"
e) En Propietario, haga clic en "Cambiar"


advanced.PNG
f) En el cuadro "Ingrese el nombre del objeto para seleccionar", escriba: Administradores y, a continuación, haga clic en "Comprobar nombres". (En ocasiones, debe utilizar el nombre de la computadora, como AMER\Administrators).

g) Haga clic en OK




administrators.PNG

h) Coloque una marca de verificación en "Replace all child object permission entries..."   y el cuadro "Reemplazar propietario en subcontenedores y objetos".

i) Haga clic en "Apply" (Aplicar) y, a continuación, haga clic en el cuadro "Yes" (Sí) para ver el cuadro "¿Desea continuar?".

j) Haga clic en "OK" (Aceptar)

se reemplazó. PNG




Affected Products

NetWorker
Article Properties
Article Number: 000214570
Article Type: Solution
Last Modified: 29 Apr 2025
Version:  6
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