Неможливо розшифрувати: BAD_DATA помилка з'являється в інтерфейсі NMC після міграції сервера NetWorker

Summary: Неможливо розшифрувати: BAD_DATA помилка може виникнути, коли виникає проблема з сейфлом, будь то пошкодження в сейфі або коли сервер NetWorker був перенесений, переміщений або перевстановлений, а блок не був скопійований поверх / відновлений. У поточній скриньці блокування не зберігаються паролі, які збігаються з паролями користувача/паролів у nsrdb, звідси і помилка BAD_DATA. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Сервер NetWorker був перенесений на нове обладнання
  • nsrdr було виконано для повернення конфігурації NetWorker
  • пароль був присвоєний полям деяких ресурсів NetWorker
  • В інтерфейсі NMC спливаюче вікно з'являється при натисканні на деякі ресурси NetWorker.

bad_data.PNG


Cause

"Неможливо розшифрувати: BAD_DATA» може виникнути, коли виникає проблема з блоком, чи то через пошкодження в сейфі, чи то коли сервер NetWorker був перенесений, переміщений або перевстановлений, а блок не був скопійований поверх/відновлений. У поточному сейфі не збережено паролів, які збігаються з паролем користувача або пароля у nsrdb, звідси і помилка BAD_DATA.

Resolution

Щоб усунути спливаюче вікно помилки BAD_DATA від NMC, замініть поточний блок на оригінальний блок із сервера NetWorker перед nsrdr або міграцією. На сервері Linux Networker експортуйте початковий блок блокування за допомогою команди nsr_prep_lb . Зверніться до Посібника з налаштування безпеки NetWorker, щоб отримати інструкції щодо експорту сейфа.

Якщо імпорт оригінального блоку неможливий, скиньте всі поля пароля в ресурсах NetWorker на порожні.

Як скинути паролі в nsrdb

1) Створіть вхідний файл з іменами паролів, які потрібно очистити в nsrdb.  Створіть файл під назвою "pass.txt", який містить такі рядки:оновити пароль:

;
y
Пароль керування оновленнями: ;
y
оновити пароль керування NAS: ;
y
оновити пароль доступу до файлу NAS: ;
y
оновити ключ автентифікації: ;
y
оновити пароль користувача VMWS: ;
y
оновити пароль EBR: ;
y
оновити пароль REST Services: ;
y
оновити пароль vCenter: ;
y
оновлення ключа конфіденційності: ;
y
оновити парольну фразу datazone: ;
y

2) Зупиніть послуги NetWorker.

У Linux: systemctl stop networker
У Windows:  Зупиніть службу резервного копіювання та відновлення сервера NetWorker і службу віддаленого виконавчого директора

NetWorker 3) Зробіть копію nsrdb. Назвіть це nsrdb.beforepassclean.

4) Запустіть команду nsradmin з вхідним файлом pass.txt.

На LInux: 

# nsradmin -i pass.txt -d /nsr/res/nsrdb У Windows:C:> nsradmin -i pass.txt -d "C:
\Program Files\EMC Networker\nsr\res\nsrdb"5

) Створити ще одну копію зміненого nsrdb

.
Назвіть це nsrdb_passwordblank. Перейменуйте теку dbg у nsrdb, якщо така є.

6) У середовищі Windows дотримуйтесь наведеної нижче процедури Змініть власника nsrdb , перш ніж перейти до кроку 7.

7) Запустіть сервіс NetWorker.

8) Запустіть NMC. На цьому етапі повторно введіть пароль, який був призначений ресурсам(-ам) NetWorker.

Зміна власника nsrdb

На сервері Windows NetWorker право власності на змінені файли nsrdb буде змінено з Адміністратори (група) на будь-якого користувача, який зараз увійшов до системи. Це призведе до того, що NetWorker пошкодить змінені записи після перезапуску, перемістивши ці файли в папку dbg. Ось чому перед запуском служб NetWorker у Windows встановіть права доступу до всіх файлів у nsrdb, щоб вони належали групі Адміністратори (не користувачеві, а групі). 

Натисніть «C:\Program Files\EMC Networker\nsr\res\nsrdb» у Файловому провіднику та встановіть право власності на всі файли та дочірні об'єкти на Адміністратори.

a) У Файловому провіднику клацніть правою кнопкою миші папку
C:\Program Files\EMC NetWorker\nsr\res\nsrdb b) Виберіть властивості.
в) Перейдіть на вкладку
«Безпека».d) Натисніть "Додатково"e) У полі Owner натисніть "Змінити"f) У полі "Введіть ім'я об'єкта для вибору"



просунутий.PNG
введіть: Адміністратори, потім натисніть «Перевірити імена». (Іноді потрібно використовувати ім'я комп'ютера, наприклад AMER\Administrators).

g) Натисніть OK




адміністраторів.PNG

h) Поставте галочку в полі "Замінити всі записи дозволів дочірнього об'єкта..."   та поле "Замінити власника на підконтейнерах та об'єктах".

i) Натисніть «Застосувати», а потім натисніть «Так» у полі «Бажаєте продовжити?».

j) Натисніть «ОК»

замінено.PNG




Affected Products

NetWorker
Article Properties
Article Number: 000214570
Article Type: Solution
Last Modified: 29 Apr 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.