SupportAssist for Home PCs not able to Launch from MyDell
Summary: This article provides more information about SupportAssist for Home PCs v4.0 not being able to be launched from the MyDell v3.1 and later application.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Affected Products:
- SupportAssist for Home PCs v4.0 or Later
- MyDell v3.1 and later
When attempting to open SupportAssist for Home PCs from MyDell, it takes you to a web page that says Something went wrong - we have trouble loading your requested page. Go back and try again.
Steps to re-create:
- Launch MyDell
- Click Applications

- Click Launch next to SupportAssist

- SupportAssist attempts to open using the default web browser.

- The error is displayed in the web browser: Something went wrong We had trouble loading your requested page. Go back and try again.

Cause
MyDell is the cause of the issue.
Resolution
Updating to MyDell version 3.2.1 or later on the computer resolves the issue. To download and install MyDell, reference How to Download and Install Dell Drivers.
Affected Products
SupportAssist for Home PCs, MyDellArticle Properties
Article Number: 000221251
Article Type: Solution
Last Modified: 05 Sept 2025
Version: 5
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