Connectrix B-Serie: Lizenzschlüssel konnte dem Switch nicht hinzugefügt werden mit Fehler "Fehler beim Commit der Lizenzänderungen"
Summary:
Lizenz kann dem MX610s-Switch nicht mit "licenseadd" hinzugefügt werden "-Befehl für FOS-Version 8.1.x. Die Befehle "license install -k" und "License -install " werden von
FOS Version 8.1.x nicht unterstützt.
...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Error:
Switch-A:admin licenseadd "W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****" adding license-key [W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****] failed to commit license changes
Cause
Supportsave und Lizenzinstallation können aufgrund des folgenden Fehlers nicht ausgeführt werden:
"The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB."
Switch-A:admin> supportsave This command collects RASLOG, TRACE, supportShow, core file, FFDC data and then transfer them to a FTP/SCP/SFTP server or a USB device. This operation can take several minutes. OK to proceed? (yes, y, no, n): [no] yes Host IP or Host Name: 10.82.50.27 User Name: username Password: ****** Protocol (ftp | scp | sftp): sftp Remote Directory: /home/inti/brocade Do you want to continue with CRA (Y/N) [N]: The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB. Please run the following commands to release disk space and retry full supportsave 1. "supportsave -k" to transfer core files to remote location 2. "supportsave -R" to remove the core files in the switch SupportSave failed.Suchen Sie nach Core-Dateien, die mit dem folgenden Befehl gelöscht werden sollen:
Switch-A:admin> supportsave -R No core or FFDC data files found! SupportSave completed.
Resolution
Es gibt mehrere Möglichkeiten, dieses Problem zu beheben:
- Korrektur 1:
- Führen Sie den folgenden Befehl aus, um zu bestätigen, ob das Root-Konto aktiviert ist.
userconfig --show root
- Entfernen Sie unter Verwendung des Root-Kontos
/var/log/esmd_lib.logDateien, die möglicherweise mehr Flash-Speicher beanspruchen
- Erfassen Sie die Ausgabe des folgenden Befehls von root.
root> ls lR /var
In dieser Ausgabe sollte Folgendes angezeigt werden:
/var/log: -rw-r--r-- 1 root root 3113586 Oct 14 11:16 esmd_lib.log -rw-r--r-- 1 root admin 14065977 Oct 13 05:17 esmd_lib.log.1 -rw-r--r-- 1 root admin 82593068 Oct 7 11:04 esmd_lib.log.2 -rw-r--r-- 1 root root 329366414 Sep 2 13:41 esmd_lib.log.3
- Geben Sie die folgenden Befehle über das Stammverzeichnis aus, um die Dateien zu entfernen:
rm /var/log/esmd_lib.log rm /var/log/esmd_lib.log.1 rm /var/log/esmd_lib.log.2
Dadurch wird der Flash-Speicher bereinigt und die
supportsave ausgeführt werden.
- Sammeln
supportsaveund installieren Sie die Lizenz mitlicenseadd <key>Befehl nach dem Bereinigen des Flash-Speichers. - Wenn das Root-Konto aktiviert ist, führen Sie den folgenden Befehl aus, um temporäre und unerwünschte Firmwaredateien zu entfernen.
df -k
Wenn das Root-Konto nicht aktiviert ist, können Sie es möglicherweise aufgrund von Speicherproblemen nicht aktivieren. Befolgen Sie Korrektur 2, wenn das Root-Konto deaktiviert ist.
Switch_A:admin> userconfig --show root Account name: root* Description: root Enabled: No Password Last Change Date: Unknown (UTC) Password Expiration Date: Not Applicable (UTC) Locked: No Role: root AD membership: 0-255 Home AD: 0 Day Time Access: N/A
Switch_A:admin> userconfig --change root -e yes sqlite3_exec error: 10 disk I/O error Failed to change user account attributes
- Korrektur 2:
- Backup der Konfiguration erstellen und
HarebootIm Wartungsfenster, um das Problem mit dem Flash-Speicher zu beheben. - Nach der Durchführung
HarebootSammelnsupportsaveund versuchen Sie, die Lizenz mithilfe vonlicenseadd <key>verwenden.
- Korrektur 3:
Wenn Korrektur 2 den Flash-Speicher nicht löschen oder das Root-Konto nicht aktivieren kann, wenden Sie sich an den Switch-Anbieter, um weitere Unterstützung zu erhalten, bevor Sie einen Switch-Austausch durchführen.
Additional Information
Referenz KB : https://www.dell.com/support/kbdoc/en-in/000064137
Affected Products
Dell EMC Networking MX-G610sArticle Properties
Article Number: 000223916
Article Type: Solution
Last Modified: 10 May 2024
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.