PowerFlex Manager -Node Expansion Fails With Error VXFM00709 For VMK MTU Inconsistencies

Summary: PFxM node expansion fails with error VXFM00709 for VMK interface MTU inconsistencies.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

During a CO or HCI node expansion, PFxM errors out with VXFM00709 due to inconsistent MTU settings on one or more VMK interfaces amongst ESXi hosts in the service/resource group.
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The VMK interface MTU configuration may appear consistent between the hosts in the cluster, i.e. vmk1 is set to 1500 on all hosts, vmk2 is set to 9000 on all hosts, etc.

Node expansion will fail. This may also impact re-adding a service or resource group after it was removed.

 

Cause

In this scenario, the management and vMotion VMK networks were configured for the same VLAN (2017) but vmk0 was configured for 1500 MTU, and vmk1 was configured for 9000 MTU.

The port-group names may be different in vCenter, but they are configured with the same VLAN ID.

This is expected behavior to ensure consistency between nodes in the same service/resource group.
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Resolution

1. Configure each VMK interface that is set to the same VLAN ID with the same MTU.

2. Remove the service or resource group from PFxM.

3. Run inventory on all relevant resources in PFxM.

4. Re-add the original service or resource group

5. Re-attempt node expansion activity

Additional Information

Impacted Versions

PowerFlex Manager 3.x

PowerFlex Manager 4.x

Fixed In Version

N/A - working as expected

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000226511
Article Type: Solution
Last Modified: 03 Feb 2025
Version:  2
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