Azure Stack: HLH upgrade A positional parameter cannot be found Inaccessible network share

Summary: The PnU tool fails to attach the HLH ISO file to the iDRAC when using a credential similar to below domain\username. A positional parameter cannot be found that accepts argument 'Inaccessible network share.' ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The PnU tool fails to attach the HLH ISO file to the iDRAC when using a credential similar to below:

Connected Console Username: domain\username

Error details: 

2025-05-08 01:55:04.350 +03:00 [INF] Settings ISO found at C:\Program Files\Dell EMC\VxRack AS Patch and Update Automation\PSScripts\HLH\Windows\OSDShare\PnU-Setup.iso
2025-05-08 01:55:04.356 +03:00 [INF] HLH ISO found at C:\Program Files\Dell EMC\VxRack AS Patch and Update Automation\PSScripts\HLH\Windows\OSDShare\MS2406_Dell2411.4_Redeployment.iso
2025-05-08 01:55:04.362 +03:00 [INF] Attaching HLH OS ISO for iDRAC 172.16.112.2.
2025-05-08 01:55:04.686 +03:00 [INF] OSD initiated successfully.
2025-05-08 01:55:05.693 +03:00 [INF] OSD Task State :
2025-05-08 01:55:05.788 +03:00 [ERR] A positional parameter cannot be found that accepts argument 'Inaccessible network share.'.
2025-05-08 01:55:05.792 +03:00 [INF] Validating iDRAC credentials and creating session
2025-05-08 01:55:05.796 +03:00 [INF] Checking connectivity for HLH iDRAC

Cause

The API for iDRAC does not work if using a domain credential "domain\username" for the Connected Console Username in the PNU automation tool. 

Resolution

To work around this issue, use a local administrator account without a domain name.

Connected Console Username: testuser
 

Connected Console Username: testuser

Affected Products

Integrated System for Microsoft Azure Stack Hub 14G

Products

Integrated System for Microsoft Azure Stack Hub, Integrated System for Microsoft Azure Stack Hub 16G
Article Properties
Article Number: 000323734
Article Type: Solution
Last Modified: 11 Jun 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.