Connectrix: MDS: Polecenie Pokaż użytkowników wyświetla nieprawidłową datę i godzinę tylko 1 stycznia 08:00

Summary: Polecenie show users zawiera informacje o użytkownikach zalogowanych w systemie. W tym artykule wyjaśniono problem polegający na nieprawidłowym wyświetlaniu daty i godziny.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Przełącznik pracuje z systemem NX-OS 9.4.1a.

Dane wyjściowe polecenia users wyświetlają nieprawidłowy znacznik czasu, jak pokazano poniżej:
[Model 9132T on NX-OS 9.4.1a]                    
===================
 
MDS9132T-s1fA-sw3# show version 
  system:    version 9.4(1a)                         <<<<<<<<<<<<<<<<<<< 9.4.1a
  system image file is:    bootflash:///m9100-s6ek9-mz.9.4.1a.bin
  system compile time:     12/25/2023 12:00:00 [01/12/2024 10:45:51]
  Reason: Reload due to non-disruptive system reload
 
MDS9132T-s1fA-sw3# sh clock
Time source is Hardware Calendar
09:55:11.833 IST Sat Jun 15 2024
 
MDS9132T-s1fA-sw3# show users
NAME     LINE         TIME         IDLE          PID COMMENT
admin    pts/0        Jan  1 05:30   .         16852 session=ssh *      <<<<<<<<<<<< Jan 1 05:30

Cause

Dzieje się tak z powodu CSCWK43183 identyfikatora defektu Cisco dotyczącego systemu NX-OS 9.4.1a.

Resolution

W systemie NX-OS w wersji 9.4(1a) wyjście show users konsekwentnie wyświetla datę 1 stycznia wraz z przesunięciem czasu UTC na podstawie skonfigurowanej strefy czasowej.

Z uwagi na to, że show users dane wyjściowe wyświetlają nieprawidłowy znacznik czasu, show accounting log Można sprawdzić najnowszy znacznik czasu logowania dla użytkownika Admin.

Obejście problemu:
When a user logs in to the switch on SSH, accounting log records the login of the user as below:
<timestamp> :type=start:id=10.138.65.80@pts/1:user=admin:cmd=
 
When a user logs into the switch on console, accounting log records the login of the user as below:
<timestamp> :type=start:id=console0:user=admin:cmd=
 
To view the last logged in time for a user named "admin", run the below command:
 # show accounting log | grep "start.*admin" | tail lines 1

Naprawiać:
Uaktualnij do wersji NX-OS 9.4.2.
DS9132T-s1fA-sw3# show version | grep sys
  system:    version 9.4(2)                     <<<<<<<<<<<<<<<<<<<<< 9.4.2
  system image file is:    bootflash:///m9100-s6ek9-mz.9.4.2.bin
  system compile time:     4/25/2024 12:00:00 [05/10/2024 03:55:39]
 
MDS9132T-s1fA-sw3# sh users
NAME     LINE         TIME         IDLE          PID COMMENT
admin    pts/0        Jun 15 10:16   .          6362 (10.1xx.x5.1x5) session=ssh *   >>>> showing correct timings
 
After downgrading the switch from version 9.4.1a to 9.3.2a, the timestamps displayed by the 'show users' command are now correct.

BIOS compile time:       05/16/2023
  kickstart image file is: bootflash:///m9300-s1ek9-kickstart-mz.9.3.2a.bin   <<<<
  kickstart compile time:  4/25/2023 12:00:00 [05/13/2023 03:09:36]
  system image file is:    bootflash:///m9300-s1ek9-mz.9.3.2a.bin
  system compile time:     4/25/2023 12:00:00 [05/13/2023 04:28:40]
 
MDS9396S-s1fB-SW1# show users
NAME     LINE         TIME         IDLE          PID COMMENT
admin    pts/0        Jun 15 15:41   .          4855 (10.1xx.2xx.x8) session=ssh *  <<<< show users displaying the correct time.
 
MDS9396S-s1fB-SW1# show clock
Time source is NTP
15:42:36.016 ist Sat Jun 15 2024
 
Nuta:
Przed wykonaniem aktualizacji do wersji 9.4.2 należy sprawdzić, czy w przełącznikach jest używany protokół uwierzytelniania TACACS.
  • Jeśli tak, CSCWK14579 wad Cisco może powodować błędy uwierzytelniania po uaktualnieniu do wersji 9.4.2. Dlatego wyłącz TACACS i przeprowadź aktualizację oprogramowania wewnętrznego. Następnie włącz konfigurację TACACS.
  • Jeśli przełączniki nie używają TACACS do uwierzytelniania, można uaktualnić do wersji 9.4(2) bez żadnych problemów.
Article Properties
Article Number: 000226156
Article Type: Solution
Last Modified: 19 May 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.