VxFlex: Alcuni dispositivi SDS crittografati tramite CloudLink contrassegnati come errore dopo il riavvio del nodo SDS
Summary: VxFlex: Alcuni dispositivi SDS crittografati tramite CloudLink contrassegnati come errore dopo il riavvio del nodo SDS
Symptoms
Dopo il riavvio dell SDS, alcuni dispositivi crittografati da CloudLink continuano a funzionare, mentre gli altri sono contrassegnati come Error.
Più dispositivi SDS contrassegnati come "Error" nello stato dell SDS riavviato. Ciò potrebbe causare una riduzione della capacità e potenzialmente un tempo di ricostruzione più lungo.
In SDS trc:
21/06 13:09:34.917236 0x7fed52ebbeb0:mosAsyncIO_OpenFileEx:00376: WARNING: Failed to open IO file /dev/mapper/svm_sdg with rc 3 21/06 13:09:34.917238 0x7fed52ebbeb0:file_OpenEx:00707: Open error /dev/mapper/svm_sdg, NOT_FOUND 21/06 13:09:34.917241 0x7fed52ebbeb0:phyDev_ReadDevId:02649: failed to open file: path=/dev/mapper/svm_sdg, NOT_FOUND
L'SDS cfg/partitions include una o più voci con i dispositivi SDS preceduti dal mapper/svm_sd e una o più senza prefisso.
L'esempio seguente mostra entrambi i tipi di voci.
8 96 1875374424 mapper/svm_sdg 8 112 1875374424 sdh The device errors can be cleared after the affected SDS has been restarted.
La versione di ScaleIO in uso è superiore a 2.0.1.3 e 000158993 della KB non si applica, anche se il sintomo è simile.
Cause
CloudLink presenta problemi con il controllo del disco e sblocca solo alcuni dispositivi prima di avviare l SDS. All'avvio dell SDS, il /dev/mapper/svm_sd* i file dei dispositivi per i dischi non ancora da sbloccare non sono ancora stati creati, segnalando quindi errori del dispositivo SDS.
Resolution
Questo problema è stato risolto nel collegamento cloud 6.8. Consultare la Support Matrix per verificare che l'ambiente sia ancora supportato.
Per risolvere questo problema, riavviare manualmente il servizio SDS e cancellare gli errori del dispositivo SDS interessato.
Per evitare che si verifichi il problema, avviare l SDS dopo che CloudLink ha sbloccato tutti i dischi:
- Prima di arrestare il nodo, eseguire "/opt/emc/scaleio/sds/bin/delete_service.sh"; dopo il riavvio, attendere che tutti i dischi utilizzati come dispositivi SDS siano sbloccati (verrà visualizzato "svm status" o il centro di controllo CloudLink) e quindi eseguire "/opt/emc/scaleio/sds/bin/create_service.sh"; o
- Modificare "/opt/emc/extra/pre_run.sh" e inserire "sleep 30" sopra l'ultima riga (valutare la possibilità di impostare questo numero 30 su un valore superiore se il problema persiste, ad esempio se non tutti i dispositivi sono sbloccati all'avvio del processo SDS):
... sleep 30 echo pre_run returned...$(date) >> /var/log/svm-sds
Additional Information
NOTA: La soluzione alternativa della sospensione di cui sopra non è inclusa in un aggiornamento (alla versione 6.7, in quanto non include ancora la correzione permanente a questo problema) e potrebbe essere necessario applicarla nuovamente.
Non si tratta di un problema del software ScaleIO. Il problema è presente nel collegamento cloud 6.6 e 6.7 ed è stato risolto nel collegamento cloud 6.8.
Mantenere #CCTFY25Q4 come parola chiave in tutte le versioni per scopi di monitoraggio.