VxFlex: Cloudlink ile şifrelenmiş bazı SDS aygıtları, SDS düğümü yeniden başlatıldıktan sonra hata olarak işaretlendi
Summary: VxFlex: Cloudlink ile şifrelenmiş bazı SDS aygıtları, SDS düğümü yeniden başlatıldıktan sonra hata olarak işaretlendi
Symptoms
SDS yeniden başlatıldıktan sonra, Cloudlink ile şifrelenmiş bazı cihazlar çalışmaya devam ederken geri kalanlar Hata olarak işaretlenir.
Yeniden başlatılan SDS'de birden fazla SDS aygıtı "Hata" durumu olarak işaretlendi. Bu, kapasitenin azalmasına ve potansiyel olarak daha uzun bir yeniden oluşturma süresine neden olabilir.
SDS trc'de:
21/06 13:09:34.917236 0x7fed52ebbeb0:mosAsyncIO_OpenFileEx:00376: WARNING: Failed to open IO file /dev/mapper/svm_sdg with rc 3 21/06 13:09:34.917238 0x7fed52ebbeb0:file_OpenEx:00707: Open error /dev/mapper/svm_sdg, NOT_FOUND 21/06 13:09:34.917241 0x7fed52ebbeb0:phyDev_ReadDevId:02649: failed to open file: path=/dev/mapper/svm_sdg, NOT_FOUND
SDS'nin cfg/partitions dosyası, SDS aygıtlarının önekli eşleyici/svm_sd olduğu bir veya daha fazla girdi ve önek içermeyen bir veya daha fazla girdi içerir.
Aşağıdaki örnekte her iki giriş türü de gösterilmektedir.
8 96 1875374424 mapper/svm_sdg 8 112 1875374424 sdh The device errors can be cleared after the affected SDS has been restarted.
Kullanılan ScaleIO sürümü 2.0.1.3'ten yüksektir ve belirti benzer olsa da KB 000158993 geçerli değildir.
Cause
CloudLink'in disk denetimiyle ilgili sorunları var ve SDS'yi başlatmadan önce yalnızca bazı aygıtların kilidini açıyor. SDS başladığında, /dev/mapper/svm_sd* Kilidi henüz açılmamış diskler için aygıt dosyaları henüz oluşturulmamıştır, bu nedenle SDS aygıt hataları bildirilir.
Resolution
Bu sorun Cloud link 6.8 de düzeltilmiştir. Ortamın hala desteklendiğinden emin olmak için destek matrisine bakın.
Bu sorunu gidermek için SDS hizmetini manuel olarak yeniden başlatın ve etkilenen SDS aygıt hatalarını temizleyin.
Sorunun oluşmasını önlemek için, CloudLink tüm disklerin kilidini açtıktan sonra SDS'yi başlatın:
- Düğümü kapatmadan önce "/opt/emc/scaleio/sds/bin/delete_service.sh" komutunu çalıştırın; yeniden başlattıktan sonra, SDS aygıtları olarak kullanılan tüm disklerin kilidi açılana kadar bekleyin ("svm durumu" veya CloudLink kontrol merkezi gösterilecektir) ve ardından "/opt/emc/scaleio/sds/bin/create_service.sh" komutunu çalıştırın; veya
- /opt/emc/extra/pre_run.sh" ifadesini düzenleyin ve son satırın üstüne "sleep 30" ifadesini ekleyin (sorun devam ediyorsa yani SDS işlemi başladığında tüm aygıtların kilidi açılmıyorsa bu sayıyı 30 üzerine ayarlamayı düşünebilirsiniz):
... sleep 30 echo pre_run returned...$(date) >> /var/log/svm-sds
Additional Information
NOT: Yukarıdaki uyku geçici çözümü bir yükseltmede değildir (bu soruna yönelik kalıcı düzeltmeyi henüz içermediğinden 6.7 ye) ve tekrar uygulanması gerekebilir.
Bu bir ScaleIO yazılım sorunu değildir. Sorun, Cloud bağlantısı 6.6 ve 6.7'dedir ve Cloud bağlantısı 6.8'de düzeltilmiştir.
İzleme amacıyla tüm sürümlerde anahtar sözcük olarak #CCTFY25Q4'ü kullanın.