CloudLink: Конфігурація KMS не працює після оновлення Cloudlink 8.1.0 до 8.2
Summary: Cloudlink8.2 має найновіші бібліотеки безпеки, які вимагають конкретних полів, які потрібно оновити у підписаному сертифікаті CA.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Конфігурація KMS не працює після оновлення Cloudlink 8.1.0 до 8.2 через неправильний підписаний сертифікат CA
Cause
Cloudlink8.2 має найновіші бібліотеки безпеки, які вимагають оновлення певних полів (виділених) у підписаному сертифікаті CA.
Наприклад, виділені поля:
openssl req -x509 -newkey rsa:4096 -keyout clusterca_key.pem -out clusterca.pem -sha256 -days 365 -addext 'keyUsage=keyCertSign' -addext "basicConstraints=critical,CA:TRUE,pathlen:0" -subj '/CN=pp-clc802-oct28-1/O=Dell/OU=ISG/ST=TX/L=RoundRock' -addext 'subjectAltName=DNS:pp-clc802-oct28-1,DNS:pp-clc802-oct28-2' -addext 'subjectKeyIdentifier=hash'Resolution
- Регенерація сертифікатів із полем CA, встановленим у true за допомогою сертифікатного авторитету CA для сервера KMIP, яким є сервер Cloudlink.
- Увійдіть у інтерфейс Cloudlink -->натисніть "KMIP SERVER" --> натисніть "Інформація" -->натисніть "Дії" -->натисніть "Завантажити CA Signed PEM"
- Після оновлення сертифікату сервера Cloudlink KMIP ми повинні генерувати нові клієнтські сертифікати KMIP для додавання до довіреної конфігурації KMS у vCenter.
- У розділі KMIP SERVER -->натисніть "Client" --> Виберіть Client -->перейдіть у "Actions" --> "Generate New Certificate"
- Ви повинні побачити, що .zip файл з ім'ям клієнта складається з трьох файлів (ca.pem, cert.pem і key.pem).
- Увійдіть у vCenter —> виберіть об'єкт vCenter ---> перейдіть на налаштування —> перейдіть до «key Provider» —> виберіть назву кластера —> виберіть «Встановити довіру» нижче —> виберіть «Make KMS trust vCenter» —> виберіть третю кнопку радіо, а далі —> завантажити cert.pem і key.pem —> натисніть «ВСТАНОВИТИ ДОВІРУ», що завершить конфігурацію.
Article Properties
Article Number: 000393850
Article Type: Solution
Last Modified: 08 Dec 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.