PowerStore: OpenLDAP Grup İzinleri Kullanılarak Oturum Açılamıyor

Summary: Grup üyesi özniteliği memberUid ise PowerStoreOS 4.1.0.0 ve sonraki sürümlerde, grup tabanlı izinlere sahip OpenLDAP hesaplarını kullanarak PowerStore Manager'da oturum açma işlemi başarısız oluyor. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerStoreOS sürüm 4.1'de bir kullanıcı grubundan erişim izinleri devralan OpenLDAP kullanıcıları için PowerStore Manager'da oturum açma işlemi başarısız oluyor. Belirli bir OpenLDAP kullanıcısına erişim eklenirse oturum açmaya izin verilir.

PowerStore Manager ayarlarında geçerli Kimlik Doğrulama yapılandırmasını doğrulayın:
Ayarlar >Güvenlik >Kimlik Doğrulaması LDAP Yapılandırmasını > Düzenle   

  • Sunucu Türü'nün OpenLDAP olduğunu doğrulayın
  • Gelişmiş Ayarlar>Grup Arama Ayarları> Üye ÖzniteliğimemberUid olarak ayarlanır

Ayarlar >Güvenlik>Kullanıcı >LDAP

  • Atanan İzin Türü bir Grup iznidir

OpenLDAP kullanıcısıyla başarısız bir oturum açma denemesinden sonra Denetleme günlüklerini doğrulayın:

Ayarlar>Güvenlik >Audit Logs

  • Kullanıcıyı oturum açmaya çalışan OpenLDAP kullanıcısı olarak filtreleyin (user@domain.com)
  • Parola kimlik doğrulamasının başarılı olduğunu ancak Yetkilendirmenin başarısız olduğunu doğrulayın:
    • User (Kullanıcı) user@domain.com Parola kimlik doğrulaması kullanılarak başarıyla oturum açıldı
    • Kullanıcı hesabı için yetkilendirme başarısız oldu: user@domain.com, talep ederken....

Cause

Kullanıcı, OpenLDAP sunucusuyla kimlik doğrulaması yapabilir ancak PowerStore kullanıcı grubu üyeliklerini alamaz.

Resolution

Geçi -ci çözüm:
İşte iki olası geçici çözüm mevcuttur:

  • Settings >Security>Users> LDAP bölümünde PowerStore'da kullanıcı tabanlı erişim izinleri atayın   
  • OpenLDAP ve PowerStore LDAP ayarlarındaki member Attribute öğesini memberUid yerine uniqueMember olarak değiştirin.
Bu ayarın her ikisinde de değiştirilmesi gerekir:
  • PowerStore >Ayarları >Güvenlik>Kimlik Doğrulaması LDAP Yapılandırmasını Düzenleme >   
Gelişmiş AyarlarGrup Arama AyarlarıÜye Özniteliği
  • İlgili kullanıcı grubu ayarlarındaki OpenLDAP sunucusu

Düzeltmek:
Bu sorunun PowerStoreOS'in gelecekteki bir sürümünde ele alınması planlanmaktadır.

Affected Products

PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200Q, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200Q, PowerStore 5200T, PowerStore 7000T

Products

PowerStore 9000T, PowerStore 9200T
Article Properties
Article Number: 000379450
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.