PowerStore: Kan ikke logge ind med OpenLDAP-gruppetilladelser
Summary: Logon på PowerStore Manager ved hjælp af OpenLDAP-konti med gruppebaserede tilladelser mislykkes på PowerStoreOS version 4.1.0.0 og nyere, hvis attributten gruppemedlem er memberUid.
Symptoms
Logon på PowerStore Manager mislykkes for OpenLDAP-brugere, der nedarver adgangstilladelser fra en brugergruppe på PowerStoreOS version 4.1. Log ind er tilladt, hvis der føjes adgang til den specifikke OpenLDAP-bruger.
Kontroller den aktuelle godkendelseskonfiguration i PowerStore Manager Indstillinger:
Indstillinger > Sikkerhed > Godkendelse > Rediger LDAP-konfiguration
- Kontroller, at servertypen er OpenLDAP
- Avancerede indstillinger> Indstillinger >for gruppesøgning Medlemsattributten er indstillet til memberUid
Indstillinger >Sikkerhed>Brugere >LDAP
- Den tildelte tilladelsestype er en gruppetilladelse
Efter et mislykket loginforsøg med OpenLDAP-brugeren skal du kontrollere overvågningslogfilerne:
Indstillinger>Sikkerhed >Auditlogfiler
- Filtrer brugeren til den OpenLDAP-bruger, der forsøgte at logge på (
user@domain.com) - Kontroller, at adgangskodegodkendelsen lykkedes, men autorisationen mislykkedes:
- Bruger
user@domain.comDer blev logget på med adgangskodegodkendelse - Godkendelse mislykkedes for brugerkontoen:
user@domain.com, mens du anmoder om....
- Bruger
Cause
Brugeren kan godkende med OpenLDAP-serveren, men PowerStore kan ikke hente brugergruppemedlemskaberne.
Resolution
Løsninger:
Her er to mulige løsninger:
- Tildel brugerbaserede adgangstilladelser på PowerStore, i Indstillinger > Sikkerhed> brugere> LDAP
- Skift medlemsattributten i OpenLDAP og PowerStore LDAP-indstillingerne til uniqueMember i stedet for memberUid.
- PowerStore-indstillinger >>Sikkerhedsgodkendelse >>Rediger LDAP-konfiguration
- OpenLDAP-serveren i de respektive brugergruppeindstillinger
Lave:
Dette problem skal efter planen løses i en fremtidig version af PowerStoreOS.