PowerStore: Неможливо увійти за допомогою дозволів групи OpenLDAP
Summary: Вхід у PowerStore Manager за допомогою облікових записів OpenLDAP з груповими правами дозволів не працює на версії PowerStoreOS версії 4.1.0.0 і новіших, якщо атрибут учасника групи є memberUid. ...
Symptoms
Увійти в PowerStore Manager не вдається для користувачів OpenLDAP, які отримують права доступу від групи користувачів у версії PowerStoreOS 4.1. Вхід дозволяється, якщо доступ додано конкретному користувачу OpenLDAP.
Перевірте поточну конфігурацію автентифікації в налаштуваннях PowerStore Manager:
Налаштування > безпеки > Аутентифікації > Редагування LDAP Конфігурація
- Перевірте, що тип сервера — OpenLDAP
- Розширені налаштування> Налаштування >групового пошуку Атрибут члена встановлено як memberUid
Місця дії >Безпека>Користувачі >LDAP
- Призначений тип дозволу — це груповий дозвіл
Після невдалої спроби входу з користувачем OpenLDAP перевірте журнали аудиту:
Місця дії>Безпека >Журнали аудиту
- Відфільтруйте користувача до користувача OpenLDAP, який намагався увійти (
user@domain.com) - Перевірте, що автентифікація за паролем була успішною, але авторизація не вдалася:
- Користувач
user@domain.comУспішно увійшов за допомогою автентифікації паролем - Авторизація не вдалася для облікового запису користувача:
user@domain.com, просячи....
- Користувач
Cause
Користувач може автентифікуватися через сервер OpenLDAP, але PowerStore не може отримати членство в групах користувачів.
Resolution
Обхідні шляхи:
Ось два можливі обхідні шляхи:
- Призначити права на доступ користувача у PowerStore, у налаштуваннях >>Security Users>LDAP
- Змініть атрибут учасника в OpenLDAP та налаштування LDAP PowerStore на uniqueMember замість memberUid.
- Налаштування >> безпеки PowerStore >Аутентифікація >Редагування LDAP Конфігурація
- Сервер OpenLDAP у відповідних налаштуваннях групи користувачів
Виправлення:
Цю проблему планують вирішити у майбутньому випуску PowerStoreOS.