Dell Unity: For mange API-anmodninger fra CSI-driveren til Unity kan forårsage SP-panik eller MGMT-tjenesten nede
Summary: For mange API-anmodninger fra CSI-driveren til Dell Unity-systemet kan forårsage panik i en SP eller MGMT-tjenesten forblive nede.
Symptoms
For mange API-anmodninger fra CSI-driveren til Dell Unity-systemet kan forårsage panik i en SP eller MGMT-tjenesten forblive nede.
Værter foretager kontinuerlige REST API-kald til Unity-systemet, hvilket resulterer i, at administrationsserveren er optaget af tusindvis af opkald.
Dell Unity MGMT-problemer opstår på grund af det høje antal API-kald.
Cause
Ældre versioner af CSM Operator (under version 1.7) og CSI Driver for Unity (under version 2.12) kan generere for mange API-anmodninger, hvilket kan få en SP til at gå i panik eller MGMT-tjenesten til at forblive nede.
Relaterede rettelser, der reducerer antallet af REST API-kald:
- CSI-driver v2.12 – deaktiverer tilstandsovervågning som standard (tilstandsovervågning oversvømmer systemet med REST API-kald, når denne indstilling er aktiveret)
- CSM Operator v1.7 – Reduktion i API-godkendelseskald (fra v1.6.1)
Den nye version deaktiverer tilstandsovervågning som standard (tilstandsovervågning, når aktiveret oversvømmer systemet med REST API-opkald)
Resolution
Løsning:
Genstart eller fejl i forhold til MGMT-tjenesterne til den anden SP bringer MGMT-tjenesterne tilbage online og tilgængelige.
Reparere:
Opgrader CSI-driveren til Unity og CSM-operatoren til følgende versioner eller derover:
- CSI-driver v2.12
- CSM-operatør v1.7
Dokumentation og links til software:
https://dell.github.io/csm-docs/v1/deployment/csmoperator/https://dell.github.io/csm-docs/docs/
Produktbemærkninger til CSI-drivere
https://kubernetes-csi.github.io/docs/
Produktbemærkninger til CSM-operatøren:
https://dell.github.io/csm-docs/docs/release/Nyheder i version v1.7
Hvad er ændret: 1415 - [FUNKTION]: Unity Consistency Update til at reducere antallet af API-godkendelseskald