Dell Unity: För många API-begäranden från CSI-drivrutinen för Unity kan orsaka SP-panik eller att MGMT-tjänsten ligger nere
Summary: För många API-förfrågningar från CSI-drivrutinen för Dell Unity-disksystemet kan orsaka panik hos en SP eller att MGMT-tjänsten förblir nere.
Symptoms
För många API-förfrågningar från CSI-drivrutinen för Dell Unity-disksystemet kan orsaka panik hos en SP eller att MGMT-tjänsten förblir nere.
Värdar gör kontinuerliga REST API-anrop till Unity-disksystemet, vilket resulterar i att hanteringsservern är upptagen med tusentals anrop.
Dell Unity MGMT-problem som uppstår på grund av det stora antalet API-anrop.
Cause
Äldre versioner av CSM Operator (nedan version 1.7) och CSI-drivrutinen för Unity (nedan version 2.12) kan generera för många API-begäranden, vilket kan orsaka panik hos en SP eller att MGMT-tjänsten förblir nere.
Relaterade korrigeringar som minskar REST API-anrop:
- CSI-drivrutin v2.12 – Inaktiverar hälsoövervakning som standard (hälsoövervakning, när den är aktiverad, översvämmar matrisen med REST API-anrop)
- CSM Operator v1.7 – Minskning av API-anrop för autentisering (från v1.6.1)
Den nya versionen inaktiverar hälsoövervakning som standard (hälsoövervakning, när den är aktiverad översvämmar matrisen med REST API-anrop)
Resolution
Lösning:
Om du startar om eller växlar över MGMT-tjänsterna till den andra SP:n blir MGMT-tjänsterna online och tillgängliga igen.
Reparera:
Uppgradera CSI-drivrutinen för Unity och CSM Operator till följande versioner eller senare:
- CSI-drivrutin v2.12
- CSM Operator v1.7
Dokumentation och länkar till programvara:
https://dell.github.io/csm-docs/v1/deployment/csmoperator/https://dell.github.io/csm-docs/docs/
Versionskommentarer för CSI-drivrutiner
https://kubernetes-csi.github.io/docs/
Versionskommentarer för CSM Operator:
https://dell.github.io/csm-docs/docs/release/Nyheter version v1.7
Vad har ändrats: 1415 – [FUNKTION]: Uppdatering av Unity-konsekvens för att minska antalet API-anrop för autentisering