Data Domain Virtual Edition (DDVE) 系統升級失敗,並出現檔案系統關閉錯誤

Summary: Data Domain Virtual Edition (DDVE) 系統升級失敗,並出現檔案系統關閉錯誤。

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Symptoms

在檔案系統關機期間,雲端提供商的任何錯誤都會導致檔案系統中止傳入要求。  這是設計的運作方式,因為重試單一雲端要求可能需要長達 5 分鐘,而且檔案系統關閉有時間限制。

以下為 ddfs.inf0 中的範例錯誤,以及隨後中止要求:搜尋「Request interrupted before retrying」。  「作用中」的雲端裝置會標記為不可用,檔案系統會以不正常關閉的情況退出。

04/12 12:06:29.060 (tid 0x1618b430): 錯誤: CAL cl_async_channel_postprocess_enqueue:672 - Request op:6 uri:https://ddvestorageaccount.blob.core.windows.net/ddvecontainer//d1/ca70f3a8/0000000000137383/0000000000000000 timeout reached after nretries:0 04/12 12:06:29.060 (tid 0x7f8b05316600): 錯誤: CAL cal_libcloud_iodone_cb:2310 - CAL I/O operation:CAL_READ_OP for object:/d1/ca70f3a8/0000000000137383/0000000000000000 returned error:Request interrupted before retrying 04/12 12:06:29.061 (tid 0x7f8b05316600): INFO: CAL cal_process_io_error:1293 - Marking cloud unit:Active as UNAVAILABLE

Cause

在檔案系統關機期間,雲端提供商的任何錯誤都會導致檔案系統在不正常的狀態下結束。

Resolution

在確認檔案系統已啟用並再次運作後,重新嘗試系統升級。

# filesys status
The filesystem is enabled and running.


注意:為降低發生此問題的機會,客戶應先停止 DDVE 上的所有活動 (接收、修復、複寫、GC),然後再執行系統升級。

如果系統持續報告升級失敗與檔案系統關閉錯誤,請聯絡 Dell EMC Data Domain 支援

Affected Products

Data Domain
Article Properties
Article Number: 000185767
Article Type: Solution
Last Modified: 12 Jan 2023
Version:  6
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