PowerEdge: Windows Inaccessible Boot Device
Summary: The server generates stop code 0x7B: Inaccessible Boot Device.
Symptoms
Anti-virus or backup software may have recently been installed, updated, or removed.
Cause
The most likely cause for the "Inaccessible Boot Device" error, aside from hardware failure or other issue preventing access to the Windows installation, is a corrupt or missing filter driver.
Webroot, Acronis ArcServe, and StorageCraft products are the most common offenders.
Resolution
1. Boot off of the appropriate Windows installation media in order to enter the WinRE.
2. From "Install Windows," select "Next" then click "Repair your computer."
3. From "System Recovery Options," select "Next" then click "Command Prompt."
4. Run "DiskPart" then "List Vol" - Make note of OS volume's drive letter.
5. Run "Exit" to leave DiskPart.
Warning: If you do not see the OS volume, run "List Disk" - If the storage is not present, you either have a hardware problem or the controller driver must be loaded (Leave DiskPart by running "Exit," copy controller driver to USB drive, connect it to server, run "drvload PATH_TO_CONTROLLER_INF_FILE").
6. Navigate to the OS volume by running "cd /d Z:\" or "Z:."
Note: Replace "Z:\" OS volume's actual drive letter which was obtained by running "List Vol" from DiskPart.
7. Navigate to the configuration directory by running "cd Z:\Windows\System32\config."
8. Run "mkdir Backup" then "copy SYSTEM Backup\SYSTEM" to make a backup of the System registry hive file.
9. Run "reg load HKLM\Temp SYSTEM" to load the System registry hive file.
10 Run "regedit" then navigate to "HKLM\Temp\ControlSet001\Control\Class."
11 Click "Edit" then "Find" or press "CTRL+F" then search for "upperfilters."
12 You are looking for third-party filter drivers that have been injected into the "UpperFilters" registry key of storage-related classes. Document the names of any foreign or unexpected filter drivers then remove them by editing the UpperFilters registry key. Click "Find Next" or press "F3" to proceed.
Default for DiskDrive Class:
Default for SmartCardReader Class:
Default for SmrDisk Class:
Default for ScmDisk Class:
Default for Volume Class:
13 If you found and removed third-party filter drivers in the previous step, navigate to "HKLM\Temp\ControlSet001\Services" then search for the name of the filter driver. Document the name of the corresponding service then set its "Start" registry key to "0" to disable it. Click "Find Next" or press "F3" to verify there are no references found.
Fourteen Close regedit then run "reg unload HKLM\Temp" to unload the System registry hive.
15 Reboot the server.
Further Considerations:
If third-party filter drivers were causing the failure, advise the customer to uninstall/reinstall the problematic software.
If third-party filter drivers are not your culprit, and hardware has been ruled out then it is back to the basics.
16 Run "bcdedit," verify that there are entries for the Windows boot manager and loader.
Example Output:
Warning: If nothing is returned by BCDEDIT a problem with the boot configuration data (BCD), troubleshoot accordingly. A potential solution would be to re-create the BCD by running "bootrec /rebuildbcd."
17 Run "Dism /Image:Z:\ /Get-Packages," verify that there are no pending updates. If there are pending updates, you can revert them by running "Dism /Image:Z:\ /Cleanup-Image /RevertPendingActions" then reboot.
18 Run "Chkdsk Z:" to perform a read-only scan. If NTFS corruption is detected, you can run "Chkdsk /f /r Z:" to perform a repair. Chkdsk is potentially destructive, that is can cause data loss.
19 Run "sfc /scannow /offbootdir=Z:\ /offwindir=Z:\Windows" to scan/attempt repair of system files.
Twenty Replace registry hive files with backups from the RegBack directory:
Run "cd Z:\Windows\System32\config."
Run "ren DEFAULT DEFAULT.old."
Run "ren SAM SAM.old."
Run "ren SECURITY SECURITY.old."
" Runren SOFTWARE SOFTWARE.old.
Run "ren SYSTEM SYSTEM.old"
Run "copy RegBack\DEFAULT DEFAULT."
Run "copy RegBack\SAM SAM."
Run "copy RegBack\SECURITY SECURITY."
Run "copy RegBack\SOFTWARE SOFTWARE."
Run "copy RegBack\SYSTEM SYSTEM."
21 Reboot the server.