Dell FluidFS: Não é possível acessar os compartilhamentos depois de atualizar para Windows 10 v1903 usando o SMB 3.1.1

Summary: Clientes Não é possível acessar compartilhamentos após a atualização para o Windows 10, versão 1903 usando o Server Message Block (SMB) 3.1.1.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Os clients Windows que usam SMB 3.1.1 perdem o acesso aos compartilhamentos SMB após a atualização para o Windows 10, versão 1903.

Cause

Esse problema ocorre devido a dois contextos de negociação encontrados no SMB 3.1.1 que não são compatíveis com o FluidFS versão 6.0.300135 e inferiores.

Resolution


Identificação do erro

O erro pode ser identificado com as seguintes mensagens de erro:

  • O cliente vê a seguinte mensagem de erro ao acessar o compartilhamento SMB: 
    Windows cannot access "\\servername" check the spelling.... Error code 0x80004005 Unspecified error
     
  • A seguinte mensagem de erro é exibida no visualizador de eventos do Windows:
    The server does not support any dialect that the client is trying to negotiate, such as the client has SMB2/SMB3 disabled and the server has SMB1 disabled.
     
  • Se estiver usando o caminho UNC (Convenção de Nomenclatura Universal):
    0x80070043 Network name cannot be found
  • Mensagem de erro em rastreamentos de rede:
    STATUS_INVALID_PARAMETER
     

Nota: Os clients SMB devem desconectar todos os compartilhamentos do servidor SMB para negociar o dialeto apropriado de acordo com o valor do parâmetro.

 
O FluidFS versão MR640 resolve esse problema. Entre em contato com o suporte e consulte este artigo.


A solução temporária alternativa está disponível seguindo as etapas abaixo para desativar o SMBv3 e usar o SMB v2.
Isso pode ser feito usando o Dell Storage Manager ou a CLI.

Para modificar a versão do SMB no MR630 mais recente, usando o Dell Storage Manager (DSM)

  1. Acesse o Dell Storage Manager. 
  2. Acesse Acessibilidade do client
  3. Selecione a guia Protocolos
  4. Selecione Editar configurações de protocolo SMB
  5. Desmarque a caixa ao lado de Protocolo SMBv3
  6. Clique em OK para salvar as configurações

Tela do protocolo SMB do Dell Storage Manager 
Figura 1: Dell Storage Manager DSM - Configurações de protocolo SMB

 

Para modificar a versão do SMB no MR630 mais recente usando cli:

Input os comandos conforme mostrado abaixo:

 

CLI/client-access/authentication/protocols/SMB-settings> view
SMBv1 Enabled                               = Yes
SMBv2 Enabled                               = Yes
SMBv3 Enabled                               = Yes
Is Required Message Signing                 = No
Is Required Message Encryption              = No
Multichannel Enabled                        = No
Leases Enabled                              = Yes
Oplocks Enabled                             = Yes
Disconnect Idle Sessions                    = No
Idle Sessions Timeout (minutes)             = 720
Idle Sessions Scan Interval (minutes)       = 720
Enable User Claims for Non-Kerberos Clients = No

CLI/client-access/authentication/protocols/SMB-settings> edit
Usage: edit [Options]



    Options:
    -EnableSMBv1 <EnableSMBv1>
    -EnableSMBv2 <EnableSMBv2>
    -EnableSMBv3 <EnableSMBv3>
    -RequireMessageSigning <RequireMessageSigning>
    -RequireMessageEncryption <RequireMessageEncryption>
    -EnableMultichannel <EnableMultichannel>
    -EnableLeases <EnableLeases>
    -EnableOplocks <EnableOplocks>
    -DisconnectIdleSessions <DisconnectIdleSessions>
    -IdleSessionsTimeout <IdleSessionsTimeout>
    -IdleSessionScanInterval <IdleSessionScanInterval>
    -EnableUserClaimsForNonKRBClients <EnableUserClaimsForNonKRBClients>

 


 Nota: Se o dialeto máximo do SMB 3.1.1 for requerido, reverta as instalações do Windows 10 versão 1903 ou do Windows Server versão 1903 para a versão anterior 1803 Geralmente Disponível (GA). 

 

 

Affected Products

Dell Compellent FS8600
Article Properties
Article Number: 000130252
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.