Dell FluidFS: Det går inte att komma åt resurser efter uppdatering till Windows 10 v1903 med SMB 3.1.1

Summary: Klienter Det går inte att komma åt resurser efter uppdatering till Windows 10 version 1903 med SMB (Server Message Block) 3.1.1.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Windows-klienter som använder SMB 3.1.1 förlorar åtkomsten till SMB-resurser efter uppdatering till Windows 10 version 1903.

Cause

Detta beror på två förhandlingskontexter som finns i SMB 3.1.1 och som FluidFS version 6.0.300135 och tidigare inte har stöd för.

Resolution


Identifiera felet

Du kan identifiera felet utifrån följande felmeddelanden:

  • Klienten ser följande felmeddelande vid åtkomst till SMB-resursen: 
    Windows cannot access "\\servername" check the spelling.... Error code 0x80004005 Unspecified error
     
  • Följande felmeddelande visas i Loggboken i Windows:
    The server does not support any dialect that the client is trying to negotiate, such as the client has SMB2/SMB3 disabled and the server has SMB1 disabled.
     
  • Om du använder UNC-sökväg (Universal Naming Convention):
    0x80070043 Network name cannot be found
  • Felmeddelande i Nätverksspårning:
    STATUS_INVALID_PARAMETER
     

Obs! SMB-klienterna måste koppla från alla SMB-serverresurser för att kunna förhandla om lämplig dialekt enligt parametervärdet.

 
FluidFS-versionen MR640 åtgärdar detta problem. Kontakta supporten och läs den här artikeln.


Den alternativa lösningen är tillgänglig genom att följa stegen nedan för att inaktivera SMBv3 och använda SMB v2 i stället.
Det kan åstadkommas med hjälp av Dell Storage Manager eller CLI.

Så här ändrar du SMB-versionen I den senaste MR630 – med Dell Storage Manager (DSM)

  1. Öppna Dell Storage Manager. 
  2. Gå till klienttillgänglighet
  3. Välj fliken Protocols (Protokoll)
  4. Välj Edit SMB Protocol Settings (Redigera SMB-protokollinställningar)
  5. Avmarkera rutan bredvid SMBv3 Protocol (SMBv3-protokoll)
  6. Klicka på OK så att inställningarna sparas

Skärmen Dell Storage Manager SMB-protokoll 
Bild 1: Dell Storage Manager DSM – SMB-protokollinställningar

 

Så här ändrar du SMB-versionen i den senaste MR630 med cli:

Mata in kommandona enligt nedan:

 

CLI/client-access/authentication/protocols/SMB-settings> view
SMBv1 Enabled                               = Yes
SMBv2 Enabled                               = Yes
SMBv3 Enabled                               = Yes
Is Required Message Signing                 = No
Is Required Message Encryption              = No
Multichannel Enabled                        = No
Leases Enabled                              = Yes
Oplocks Enabled                             = Yes
Disconnect Idle Sessions                    = No
Idle Sessions Timeout (minutes)             = 720
Idle Sessions Scan Interval (minutes)       = 720
Enable User Claims for Non-Kerberos Clients = No

CLI/client-access/authentication/protocols/SMB-settings> edit
Usage: edit [Options]



    Options:
    -EnableSMBv1 <EnableSMBv1>
    -EnableSMBv2 <EnableSMBv2>
    -EnableSMBv3 <EnableSMBv3>
    -RequireMessageSigning <RequireMessageSigning>
    -RequireMessageEncryption <RequireMessageEncryption>
    -EnableMultichannel <EnableMultichannel>
    -EnableLeases <EnableLeases>
    -EnableOplocks <EnableOplocks>
    -DisconnectIdleSessions <DisconnectIdleSessions>
    -IdleSessionsTimeout <IdleSessionsTimeout>
    -IdleSessionScanInterval <IdleSessionScanInterval>
    -EnableUserClaimsForNonKRBClients <EnableUserClaimsForNonKRBClients>

 


 Obs! Om maximal dialekt-SMB 3.1.1 krävs återställer du installationerna för Windows 10 version 1903 eller Windows Server version 1903 till den tidigare allmänt tillgängliga versionen (GA) (1803). 

 

 

Affected Products

Dell Compellent FS8600
Article Properties
Article Number: 000130252
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.