Dell FluidFS: Får ikke tilgang til delte ressurser etter oppdatering til Windows 10 v1903 ved hjelp av SMB 3.1.1

Summary: Klienter Får ikke tilgang til delte ressurser etter oppdatering til Windows 10, versjon 1903 ved hjelp av Server Message Block (SMB) 3.1.1.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Windows-klienter som bruker SMB 3.1.1, mister tilgangen til delte SMB-ressurser etter oppdatering til Windows 10, versjon 1903.

Cause

Dette problemet skyldes to forhandlingskontekster i SMB 3.1.1 som ikke støttes av FluidFS versjon 6.0.300135 og eldre.

Resolution


Identifisere feilen

Feilen kan identifiseres fra følgende feilmeldinger:

  • Klienten ser følgende feilmelding under tilgang til den delte SMB-ressursen: 
    Windows cannot access "\\servername" check the spelling.... Error code 0x80004005 Unspecified error
     
  • Følgende feilmelding vises i Windows hendelsesliste:
    The server does not support any dialect that the client is trying to negotiate, such as the client has SMB2/SMB3 disabled and the server has SMB1 disabled.
     
  • Hvis du bruker UNC-banen (Universal Naming Convention):
    0x80070043 Network name cannot be found
  • Feilmelding i nettverkssporinger:
    STATUS_INVALID_PARAMETER
     

Merk: SMB-klientene må koble fra alle SMB-serverressursene for å forhandle om riktig dialekt i henhold til parameterverdien.

 
FluidFS-versjon MR640 løser dette problemet. Kontakt kundestøtte og referanse til denne artikkelen.


Den alternative løsningen er tilgjengelig ved å følge trinnene nedenfor for å deaktivere SMBv3 og bruke SMB v2 i stedet.
Dette kan gjøres ved hjelp av Dell Storage Manager eller ved hjelp av CLI.

Slik endrer du SMB-versjonen I den nyeste MR630 – ved hjelp av Dell Storage Manager (DSM)

  1. Åpne Dell Storage Manager. 
  2. Gå til klienttilgjengelighet
  3. Velg fanen Protokoller
  4. Velg Rediger SMB-protokollinnstillinger
  5. Fjern avmerkingen i boksen ved siden av SMBv3-protokoll
  6. Klikk på OK for å lagre innstillingene

Skjermbildet for SMB-protokoll for Dell Storage Manager 
Figur 1: Dell Storage Manager DSM – SMB-protokollinnstillinger

 

Slik endrer du SMB-versjonen: I den nyeste MR630 bruker du cli:

Input kommandoene som vist nedenfor:

 

CLI/client-access/authentication/protocols/SMB-settings> view
SMBv1 Enabled                               = Yes
SMBv2 Enabled                               = Yes
SMBv3 Enabled                               = Yes
Is Required Message Signing                 = No
Is Required Message Encryption              = No
Multichannel Enabled                        = No
Leases Enabled                              = Yes
Oplocks Enabled                             = Yes
Disconnect Idle Sessions                    = No
Idle Sessions Timeout (minutes)             = 720
Idle Sessions Scan Interval (minutes)       = 720
Enable User Claims for Non-Kerberos Clients = No

CLI/client-access/authentication/protocols/SMB-settings> edit
Usage: edit [Options]



    Options:
    -EnableSMBv1 <EnableSMBv1>
    -EnableSMBv2 <EnableSMBv2>
    -EnableSMBv3 <EnableSMBv3>
    -RequireMessageSigning <RequireMessageSigning>
    -RequireMessageEncryption <RequireMessageEncryption>
    -EnableMultichannel <EnableMultichannel>
    -EnableLeases <EnableLeases>
    -EnableOplocks <EnableOplocks>
    -DisconnectIdleSessions <DisconnectIdleSessions>
    -IdleSessionsTimeout <IdleSessionsTimeout>
    -IdleSessionScanInterval <IdleSessionScanInterval>
    -EnableUserClaimsForNonKRBClients <EnableUserClaimsForNonKRBClients>

 


 Merk: Hvis maksimum dialekt SMB 3.1.1 kreves, tilbakestiller du Windows 10 versjon 1903- eller Windows Server versjon 1903-installasjonene til forrige generelt tilgjengelige versjon (GA) (1803). 

 

 

Affected Products

Dell Compellent FS8600
Article Properties
Article Number: 000130252
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.