Dell Unity: Nach einem OE-Upgrade oder EINEM SP-Neustart wird das benutzerdefinierte Sicherheitsbanner nicht mehr in der CLI angezeigt (von Dell korrigierbar).
Summary: Es wurde ein Problem festgestellt, bei dem ein benutzerdefiniertes Banner bei der Anmeldung bei der Unity-CLI oder der externen uemcli nicht mehr vorhanden war. Dies trat nach den letzten Dell Unity OE-Upgrades von 5.1.2 auf. oder 5.2.0 bis 5.2.1.x. Das benutzerdefinierte Sicherheitsbanner wurde bei der Anmeldung in Unisphere korrekt angezeigt. Jedes Mal, wenn ein SP neu gestartet wird oder ein OE-Upgrade und beide SPs in kontrollierter Reihenfolge neu gestartet werden, wurde das Problem beobachtet. ...
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Symptoms
Es wurde versucht, das Problem zu beheben, indem das Banner mithilfe des svc_banner Befehlsvorgangs erneut hinzugefügt wurde. Es war nicht erfolgreich. Dies finden Sie auf Seite 9 und 10 der Dokumentation "Dell Unity™ Family Service Commands Technical Notes". Dies war nicht erfolgreich.
Der folgende Link zeigt den benutzerdefinierten Bannerprozess an.
https://www.dell.com/support/manuals/en-us/unity-350f/unity_p_svc_cmd_tech_notes/apply-custom-log-on-banners-svc_banner?guid=guid-5a9eeff7-23e6-49a8-8053-03eec9f02aff⟨=en-usDas Problem tritt auf, wenn:
Der folgende Link zeigt den benutzerdefinierten Bannerprozess an.
https://www.dell.com/support/manuals/en-us/unity-350f/unity_p_svc_cmd_tech_notes/apply-custom-log-on-banners-svc_banner?guid=guid-5a9eeff7-23e6-49a8-8053-03eec9f02aff⟨=en-usDas Problem tritt auf, wenn:
- Die SPs werden einzeln neu gestartet.
- Beide SPs werden im Rahmen eines OE-Upgrades mit OE 5.1.x und höher neu gestartet.
Cause
Die Technische Abteilung von Dell arbeitet an einer dauerhaften Lösung für dieses Problem, die in einer zukünftigen OE-Codeaktualisierung veröffentlicht wird.
Resolution
Das Engineering hat festgestellt, dass es einen Workaround gibt, der verwendet werden kann, bis eine vollständige Korrektur in einem zukünftigen OE-Code hinzugefügt wird. Es gibt noch keinen Zeitplan für die dauerhafte Lösung.
Der folgende Befehl muss nach jedem Sp-Neustart oder Codeupgrade für jeden SP ausgegeben werden. Dadurch wird das zuvor gespeicherte Banner aus dem nichtflüchtigen Speicher im SP abgerufen.
Problemumgehung:
zu überprüfen, um vom primären SP zum Peer-SP zu gelangen: ssh peer
Um zum primären SP-Typ zurückzukommen: exit
Hinweis: Dieser Befehl kann allen benutzerdefinierten SP-Neustartskripten hinzugefügt werden, die ein Kunde verwendet, damit das Banner automatisch neu geladen wird.
Der folgende Befehl muss nach jedem Sp-Neustart oder Codeupgrade für jeden SP ausgegeben werden. Dadurch wird das zuvor gespeicherte Banner aus dem nichtflüchtigen Speicher im SP abgerufen.
Problemumgehung:
svc_banner -a
Example output: 01:40:30 service@Unity500-R14 spa:~/user# svc_banner -a INFO: checking system state ... (spa) INFO: checking system state ... (spb) INFO: Banner activated! (spb) INFO: operation successful (spb)! INFO: Banner activated! (spa) INFO: operation successful (spa)!Sobald das Banner aus dem nichtflüchtigen SP-Speicher neu befüllt und aktiviert ist, kann es mit folgendem Befehl überprüft werden:
svc_banner --dumpKann denselben Befehl verwenden, um auf dem Peer-SP
zu überprüfen, um vom primären SP zum Peer-SP zu gelangen: ssh peer
Um zum primären SP-Typ zurückzukommen: exit
Hinweis: Dieser Befehl kann allen benutzerdefinierten SP-Neustartskripten hinzugefügt werden, die ein Kunde verwendet, damit das Banner automatisch neu geladen wird.
Affected Products
Dell EMC UnityArticle Properties
Article Number: 000211513
Article Type: Solution
Last Modified: 29 Mar 2023
Version: 1
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