Offline Reset Failure When Language Selected on SupportAssist OS Recovery Tool Is Arabic

Summary: When offline reset is performed using Media key (Arabic language pack supported) and selected language is Arabic with SupportAssist OS Recovery Tool (5.5.0.16041 version), reset fails.

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Symptoms

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Offline Reset Failure When Language Selected on Dell SupportAssist OS Recovery Tool Is Arabic

 

If Arabic is the selected language in SupportAssist OS Recovery Tool and offline reset is done using Media key with Arabic as supported language, the reset process fails.

SupportAssist_Arabic_1

(Figure 1: SupportAssist OS Recovery in Arabic)

SupportAssist_Arabic_2

(Figure 2: Error Massage in Arabic)

Impacted Platform Configurations:

  • All platforms that support Media key with supported Arabic language pack.

Affected Versions:

  • The SupportAssist OS Recovery Tool of version 5.5.0.16041
 


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Cause

In 5.5.0.16041 version of Dell/Alienware SupportAssist OS Recovery Tool, the selected language code is checked against the supported language list of the operating system file present in the Media key for offline mode.
If no match is found, it throws exception for unsupported language which makes the reset process fail.


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Resolution

If the user wants to reset and Operating System language to be selected as Arabic:

  1. Perform offline reset by selecting Dell/Alienware SupportAssist OS Recovery Tool language as English.
  2. After the reset is complete, Boot to Windows.
  3. Go to Language Settings in Windows.
  4. Change Windows display language to Arabic.
  5. If the language pack is not available, connect to the Internet, download the language pack from Microsoft store and select it as the display language.


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Affected Products

SupportAssist OS Recovery
Article Properties
Article Number: 000192229
Article Type: Solution
Last Modified: 07 Oct 2021
Version:  1
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