MHC Azure Stack 14G | Admin portal reporting Local health system on node-X is unavailable
Summary: The Admin Portal is reporting 'local health system on node X is unavailable'.
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Symptoms
The Admin Portal is reporting 'Local health system on azs-S1-N04.azurestack.local is unavailable. This might impact the availability of health and monitoring functionality"
Name: “Local health system unavailable” Severity: “Warning” Component: “Capacity” Description: Local health system on S1-N11.azurestack.local is unavailable. This might impact the availability of health and monitoring functionality” Created: 13/02/2024 @ 11:19am Updated: 14/02/2024 @ 09:05am Name: “Local health system unavailable” Severity: “Warning” Component: “Capacity” Description: Local health system on S1-N12.azurestack.local is unavailable. This might impact the availability of health and monitoring functionality” Created: 13/02/2024 @ 11:19am Updated: 14/02/2024 @ 09:05am
After logging into the IDRACs, both nodes are healthy and green.
There is no change to the iDRAC configuration to the Emergency Recovery Console Server (ERCS).
Cause
1. This warning may reflect the physical degradation of the node or a connection issue to the node across the network.
2. It can also be caused by the HealthAgent service being in a stopped or down state, as was in this case.
2. It can also be caused by the HealthAgent service being in a stopped or down state, as was in this case.
icm node-X {get-service healthagent}
Resolution
1. If you see the above warning, check the hardware of the server by logging into the iDRAC. Verify the hardware health of the server.
2. If everything is in a healthy hardware status, the software health status may not be detected.
NOTE: If unable to open a PEP session, you could effectively reboot the scale node by draining it, stopping it, starting it and resuming it. That should start the service on boot.
2. If everything is in a healthy hardware status, the software health status may not be detected.
- If that is the case, log in to a PEP session and break the glass to check health status for each node.
icm node-X {get-service healthagent}
- If the status is "Stopped" in the PowerShell command line, manually start it using the command below
icm node-X {start-service healthagent -verbose}
- After running the start-service command, rerun the "get-service" command to check the health agent service.
icm node-X {get-service healthagent}
- Wait for five minutes and refresh the admin portal. The related warning should be cleared automatically.
NOTE: If unable to open a PEP session, you could effectively reboot the scale node by draining it, stopping it, starting it and resuming it. That should start the service on boot.
Article Properties
Article Number: 000222057
Article Type: Solution
Last Modified: 14 Feb 2024
Version: 1
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