NetWorker: NMDA Sybase Backup Fails with ct_connect Network Packet Error

Summary: NetWorker Module for Databases and Applications (NMDA) fails to complete Sybase backups due to a network packet error during connection initialization. The issue is typically linked to transaction log space exhaustion in the sybmgmtdb database. ...

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Symptoms

NMDA Sybase backup fails with the following logged messages:

  • From nsrsdasv log:
nsrdasv: CT-LIBRARY error: ct_connect(): network packet layer: internal net library error: Net-Library operation terminated due to disconnect
nsrdasv: Unable to log in to the ASE database.
srdasv: The child nsrdasv exited with a non-zero return code: 139
  • From NetWorker server daemon.log:
<Client name>:SYBASE/<Sybase server>: retried 1 times.
  • From SAP ASE log:
server  1 task(s) are sleeping waiting for space to become available in the log segment for database sybmgmtdb

Cause

One or more of the following conditions can cause the backup to fail:

  • Log Segment Full: The transaction log for sybmgmtdb has reached capacity.
  • trunc log on chkpt Enabled: Log truncation may fail if open transactions exist or if log and data share the same segment.
  • Log Dumping Fails: Configuration issues or segment overlap may prevent successful log dumps.
  • Auto-Expansion Not Configured: ASE does not autoexpand devices unless explicitly configured.

Resolution

Engage the SAP ASE Database Administrator to investigate and resolve the issue. Recommended actions include:

  • Increase Device and Log Segment Space

    • Resize the log device and extend the database log segment:
disk resize name = 'sybmgmtdb_log_device', size = '150M'
go

alter database sybmgmtdb on sybmgmtdb_log_device = '100M'
go
  • Dump the Database
    • Perform a full database dump to clear the transaction log:
dump database sybmgmtdb to 'path_to_backup_file'
go
Article Properties
Article Number: 000372527
Article Type: Solution
Last Modified: 05 Dec 2025
Version:  2
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