NVP-vProxy: Los respaldos fallan con el código de recurso no encontrado -404 "Sesión inactiva obsoleta"
Summary: Los respaldos de máquinas virtuales (VM) realizados con el dispositivo vProxy de NetWorker VMware Protection (NVP) fallan de forma intermitente con un error "Recurso no encontrado" (código -404) debido a que el vProxy agota la antigüedad de una sesión de respaldo completada antes de que NetWorker Server recupere el estado final. La alta latencia de red entre el nodo de almacenamiento de NetWorker y Data Domain hace que NetWorker Server retrase sus solicitudes de sondeo de estado, lo que permite que la sesión de vProxy venza. La reducción de la latencia del nodo de almacenamiento a Data Domain por debajo de 50 ms resuelve el problema. ...
Symptoms
La integración de NetWorker VMware Protection (NVP) utiliza un dispositivo vProxy para realizar respaldos de VM. Los respaldos de VM fallan de forma intermitente con un mensaje Recurso no encontrado en NetWorker Management Console (NMC). Un reintento de respaldo posterior para la misma máquina virtual puede realizarse correctamente, pero la falla puede afectar a otras máquinas virtuales en la misma ventana de respaldo. NMC muestra el siguiente error (el ID de sesión varía según la instancia):
{"Text":"Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9","Code":-404}
El registro de acciones de respaldo muestra los intentos incorrectos de NetWorker Server para recuperar el estado del respaldo desde el vProxy, seguidos de la falla del respaldo:
MM/DD/YY HH:MM:SS [VM_NAME]: Unable to obtain backup status from vProxy after 5 attempts, failing the backup: Received an HTTP code: 404, libCURL message: "", vProxy message: "Error received from vProxy ="-404: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9". ", url: "https://[VPROXY_NAME]:9090/api/v1/BackupVmSessions/44ab916f-7519-40f9-9d2e-e90394782ed9", body: " ". MM/DD/YY HH:MM:SS [VM_NAME]: Unable to download vProxy Session log into file '/nsr/logs/policy/VMWare Protection/[WORKFLOW]/461300-[VM_NAME]-YYYY-MM-DD-HH-MM-SS.log': Possible wrong vProxy hostname or port, resource path not found. Received an HTTP code: 404, libCURL message: "", url: "https://[VPROXY_NAME]:9090/api/v1/BackupVmSessions/44ab916f-7519-40f9-9d2e-e90394782ed9/log". MM/DD/YY HH:MM:SS [VM_NAME]: Backup failed. MM/DD/YY HH:MM:SS The size of proxied data written has not been set. MM/DD/YY HH:MM:SS Save-set ID '849786629' (client '[VCENTER_NAME]': save-set 'vm:50308677-bf8b-c786-0140-6a9c4409b90f:[VCENTER_NAME]') is aborted.
El vProxy vbackupd-engine.log muestra el ciclo de vida de la sesión completo: el respaldo se completa correctamente en el lado del vProxy, pero la sesión se vuelve obsoleta y se elimina posteriormente antes de que NetWorker Server recupere el estado:
YYYY/MM/DD HH:MM:SS TRACE: Ending go routine of main session loop for *resources.BackupVmSessions (vm-29424) [VM_NAME].
YYYY/MM/DD HH:MM:SS NOTICE: 44ab916f-7519-40f9-9d2e-e90394782ed9:vm-29424:[VM_NAME]: Backup session is exiting
YYYY/MM/DD HH:MM:SS TRACE: Resource Update 44ab916f-7519-40f9-9d2e-e90394782ed9:externalId=[VCENTER_NAME]:vm-29424:state=Success:deletable=true.
YYYY/MM/DD HH:MM:SS INFO: Saved resource map to "/opt/emc/vproxy/runtime/state/vbackupd/BackupVmSessions.gob".
YYYY/MM/DD HH:MM:SS NOTICE: Aging out inactive session BackupVmSessions - 44ab916f-7519-40f9-9d2e-e90394782ed9 ([VCENTER_NAME]:vm-29424) last accessed YYYY-MM-DD HH:MM:SS -0500 CDT.
YYYY/MM/DD HH:MM:SS TRACE: Deleting logfiles of session '44ab916f-7519-40f9-9d2e-e90394782ed9'...
YYYY/MM/DD HH:MM:SS TRACE: Deleting log file "/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log" while deleting session "44ab916f-7519-40f9-9d2e-e90394782ed9"...
YYYY/MM/DD HH:MM:SS INFO: File '/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log' is moved to '/opt/emc/vproxy/runtime/logs/recycle/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log'.
YYYY/MM/DD HH:MM:SS INFO: Deleted log file "/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log" while deleting session "44ab916f-7519-40f9-9d2e-e90394782ed9".
YYYY/MM/DD HH:MM:SS TRACE: Deleting resource: [VCENTER_NAME]:vm-29424 - 44ab916f-7519-40f9-9d2e-e90394782ed9 ...
YYYY/MM/DD HH:MM:SS INFO: Deleted resource: [VCENTER_NAME]:vm-29424 - 44ab916f-7519-40f9-9d2e-e90394782ed9.
YYYY/MM/DD HH:MM:SS INFO: Saved resource map to "/opt/emc/vproxy/runtime/state/vbackupd/BackupVmSessions.gob".
YYYY/MM/DD HH:MM:SS INFO: Aged out 1 'BackupVmSessions' sessions, 0 remaining
YYYY/MM/DD HH:MM:SS ERROR: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS TRACE: Handling Action GetLog for 44ab916f-7519-40f9-9d2e-e90394782ed9 ...
YYYY/MM/DD HH:MM:SS ERROR: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS TRACE: Reply sent successfully for "GetLog".
Cause
NetWorker Server sondea continuamente el vProxy para detectar el estado de la sesión de respaldo y solicita los registros de sesión una vez que se completa el respaldo. El vProxy completa el respaldo y envejece la sesión después de que NetWorker Server no solicita una actualización durante un par de minutos. A medida que la sesión se vuelve antigua, el vProxy ya no puede proporcionar al servidor de NetWorker una actualización de estado o registros y falla con el resource not found Error. Las demoras en la solicitud de estado de NetWorker Server generalmente se deben a la alta latencia entre el nodo de almacenamiento de NetWorker y la comunicación de Data Domain.
Resolution
- Mida la latencia del nodo de almacenamiento a Data Domain:
- Ejecute un ping continuo con marca de tiempo desde el nodo de almacenamiento de NetWorker a Data Domain y envíe los resultados a un archivo. Asegúrese de que las zonas horarias de ambos sistemas coincidan.
- Windows:
ping -t [DATA_DOMAIN_IP] > ping_output.txt - Linux:
ping [DATA_DOMAIN_IP] | while read line; do echo "$(date): $line"; done > ping_output.txt
- Windows:
- Deje el ping en ejecución en segundo plano durante una ventana de respaldo.
- Cuando se repita la falla de respaldo, revise el archivo de ping_output.txt y compruebe el rango de tiempo correspondiente a la falla para los picos de latencia.
- Ejecute un ping continuo con marca de tiempo desde el nodo de almacenamiento de NetWorker a Data Domain y envíe los resultados a un archivo. Asegúrese de que las zonas horarias de ambos sistemas coincidan.
- Reduzca la latencia a menos de 50 ms:
- Identifique y resuelva el origen de alta latencia entre el nodo de almacenamiento de NetWorker y Data Domain. Entre las causas comunes se incluyen la congestión de la red, los enlaces WAN, las ineficiencias de enrutamiento o la sobrecarga de los equipos de red.
- Asegúrese de que la latencia de ida y vuelta entre el nodo de almacenamiento de NetWorker y Data Domain permanezca por debajo de 50 ms durante la ejecución del respaldo. Este umbral se documenta en la sección "Consideraciones sobre el tamaño de la ventana TCP y la latencia de red" de la Guía de planificación de la optimización del rendimiento de Dell NetWorker.
- Implemente un nodo de almacenamiento remoto (si no se puede reducir la latencia):
- Si la latencia del nodo de almacenamiento a Data Domain no se puede reducir por debajo de 50 ms (por ejemplo, debido a la separación geográfica), configure un nodo de almacenamiento de NetWorker en el sitio remoto donde reside Data Domain. Este nodo de almacenamiento administra los dispositivos Data Domain localmente, lo que elimina la ruta de alta latencia.
- Verifique la resolución:
- Después de reducir la latencia o implementar un nodo de almacenamiento remoto, active trabajos de respaldo para las VM afectadas anteriormente.
- Confirme que los respaldos se completen correctamente sin errores de recurso no encontrado (código -404) en NMC, el registro de acciones de respaldo o el vbackupd-engine.log vProxy.
- Monitoree los trabajos de respaldo en 3 ventanas de respaldo consecutivas para confirmar que ya no se produzcan fallas intermitentes.
- Si las fallas de caducidad de sesión persisten después de reducir la latencia por debajo de 50 ms, comuníquese con el soporte de Dell para realizar una investigación más detallada y consulte este artículo de la base de conocimientos.
Additional Information
En el siguiente artículo, se detalla cómo realizar algunas soluciones de problemas de red: NetWorker: Cómo solucionar problemas relacionados con la red.