PowerStore: Sporadiske dataindsamlingsfejl, begrænsninger for servicebeholder OOM Python 2

Summary: Periodiske dataindsamlingsfejl pga. OOM (Service Container Out-Of-Memory) Python 2-begrænsning

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Der kan forekomme periodiske fejl i dataindsamlingsjob, hvor en af statusmeddelelserne rapporterer:

FAILURE, Running too long.

Cause

  • Der kan forekomme periodiske fejl i dataindsamlingsjob på grund af en OOM-tilstand i servicebeholderen på en primær node.
  • Denne hukommelsesoptimering og begrænsninger i affaldsindsamling i Python 2 kan forårsage problemet, hvilket fører til øget hukommelsesforbrug af service_serviceability og fireman processer i hvert dataindsamlingsjob og til sidst opleve OOM-tilstanden.
  • Der er større sandsynlighed for, at problemet opstår, hvis der er konfigureret en ekstern syslog-server, men det kan også ske afhængigt af miljøet eller konfigurationen.

Resolution

Problemet er løst i PowerStoreOS 4.1 og nyere.

Affected Products

PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore Expansion Enclosure, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore Rack, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 5200T , PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T ...
Article Properties
Article Number: 000318294
Article Type: Solution
Last Modified: 11 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.