PowerStore: Zeitweilige Fehler bei der Datenerfassung, Servicecontainer-OOM Einschränkungen für Python 2

Summary: Gelegentliche Fehler bei der Datenerfassung aufgrund von Servicecontainer-Out-of-Memory (OOM) Python 2-Einschränkung

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Es können zeitweilige Fehler bei Datenerhebungsjobs auftreten, wobei eine der Statusmeldungen Folgendes meldet:

FAILURE, Running too long.

Cause

  • Zeitweilige Fehler bei Datenerhebungsjobs können aufgrund einer OOM-Bedingung im Servicecontainer auf einem primären Node auftreten.
  • Diese Einschränkungen bei der Speicheroptimierung und der automatischen Speicherbereinigung in Python 2 können das Problem verursachen, was zu einer erhöhten Speichernutzung durch die service_serviceability und fireman verarbeitet werden in jedem Datenerhebungsjob und schließlich das Eintreten der OOM-Bedingung.
  • Das Problem tritt mit größerer Wahrscheinlichkeit auf, wenn ein Remote-Syslog-Server konfiguriert ist, kann aber auch je nach Umgebung oder Konfiguration auftreten.

Resolution

Das Problem wurde in PowerStoreOS 4.1 und höher behoben.

Affected Products

PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore Expansion Enclosure, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore Rack, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 5200T , PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T ...
Article Properties
Article Number: 000318294
Article Type: Solution
Last Modified: 11 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.