PowerStore: Періодичні збої збору даних, обмеження сервісного контейнера OOM Python 2

Summary: Періодичні збої збору даних через обмеження Python 2 у сервісному контейнері (OOM)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Можуть періодично виникати збої в роботі зі збору даних, при цьому одне з повідомлень про статус повідомляє:

FAILURE, Running too long.

Cause

  • Періодичні збої завдань зі збору даних можуть виникати через стан OOM у сервісному контейнері на основному вузлі.
  • Ця оптимізація пам'яті та обмеження на збір сміття в Python 2 можуть спричинити проблему, що призведе до збільшення використання пам'яті service_serviceability і fireman процесів у кожному завданні зі збору даних і в кінцевому підсумку відчуваючи стан OOM.
  • Проблема частіше виникає, якщо налаштовано віддалений сервер системного журналу, але також може виникати залежно від середовища або конфігурації.

Resolution

Цю проблему вирішено в PowerStoreOS 4.1 і пізніших версіях.

Affected Products

PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore Expansion Enclosure, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore Rack, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 5200T , PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T ...
Article Properties
Article Number: 000318294
Article Type: Solution
Last Modified: 11 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.