PowerFlex: STORAGE_POOL_UNBALANCED SIO02.04.0000009

Summary: This article explains the meaning of Dial Home Symptom code SIO02.04.0000009 and how to troubleshoot it.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The below alert can be observed in the PowerFlex Manager log events and Dial Home SIO02.04.0000009 will be triggered. 

The Storage Pool relies too heavily (over 50%) on capacity from a single SDS or Fault Set.

Balance capacity over other SDSs or Fault Sets.

Cause

This alert can be triggered if you have SDSs or Fault Sets that are not equal in size which may result in one SDSs or Fault Set is handling 50% of the Storage Pool (SP) workload. 

 

 

Resolution

If the SDSs or Fault sets are not symmetrical and equal in size, the recommended fix for this alert is to move some physical disks from the large SDS to the others or add disks to the smaller SDS in order to approximate the capacity of the large SDS as much as possible. 

 

However, if your SDSs or Fault Sets are equal in size or not big different in size between them, this alert can be cosmetic and will be cleared by itself after few seconds as shown in the screenshot in the Symptoms section. 

 

Note: ensure that you have the Rebalance Feature enabled for the given Storage Pool 

1- Go to Block => Storage Pools => Select the SP in Question => Modify => General Settings. 

PowerFlex Storage pool general settings

 

2- In General Settings for the given Storage Pool ensure that Enable Rebuild/Rebalance is checked. 

PowerFlex enable Rebuild rebalance for storage pool

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000381561
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  1
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