NVP vProxy: Všechny zálohy VMware selhaly a vrátily chybu "curl_easy_perform". 60: "SSL certifikát"

Summary: Všechny zálohy virtuálního počítače (VM) NetWorker VMware Protection (NVP) selhávají. Úloha hlásí, že certifikát používaný serverem vProxy je nesprávný.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Všechny zálohy virtuálních počítačů selžou s následující chybou v protokolech akcí:

MM/DD/YY HH:mm:SS Action backup vmware-vproxy 'ACTION_NAME' has initialized as 'vproxysave job' with job id 2080030
MM/DD/YY HH:mm:SS Starting nsrvim.
MM/DD/YY HH:mm:SS Calling the nsrvim program to collect the inventory data.
MM/DD/YY HH:mm:SS Setting default timeout 1800.
MM/DD/YY HH:mm:SS Using a timeout of 1800 seconds for the nsrvim request. Minimum timeout is 360 seconds. Maximum timeout is 3600 seconds.
MM/DD/YY HH:mm:SS Getting list of VM work items.
MM/DD/YY HH:mm:SS Transport mode selected from the user for backup: 'Auto'.
MM/DD/YY HH:mm:SS Saving the backup data in the pool 'POOL_NAME'.
MM/DD/YY HH:mm:SS Received the media management binding information on the host 'NW_SERVER_NAME'.
MM/DD/YY HH:mm:SS Connected to the nsrmmd process on the host 'NW_SERVER_NAME'.
MM/DD/YY HH:mm:SS VM_NAME: Perform incremental backup.
MM/DD/YY HH:mm:SS VM_NAME: Using backup mode 'VSS'.
MM/DD/YY HH:mm:SS VM_NAME: Unable to start backup on vProxy 'VPROXY_NAME': libCURL: function "curl_easy_perform" returned error 60: "SSL certificate problem: invalid CA certificate" .
MM/DD/YY HH:mm:SS Summary of VMs: after iteration 1
MM/DD/YY HH:mm:SS   0 canceled backups
MM/DD/YY HH:mm:SS   1 failed backups
MM/DD/YY HH:mm:SS   0 VMs not in inventory
MM/DD/YY HH:mm:SS   0 successful backups
MM/DD/YY HH:mm:SS   0 waiting backups
MM/DD/YY HH:mm:SS   0 running backups
MM/DD/YY HH:mm:SS   0 savesets output to next action

Protokoly akcí se nacházejí na serveru NetWorker:

K této chybě dochází na serveru NetWorker. Na serveru vProxy nejsou žádné protokoly, které by odpovídaly výše uvedenému selhání. K problému dochází před navázáním relace s vProxy.

Mezi serverem vProxy a serverem NetWorker nedošlo k žádným problémům s komunikací. Oba hostitelé se mohou vyřešit navzájem a připojit se pomocí portu 9090: NVP vProxy: Odstraňování problémů se síťovým připojením pro operace zálohování a obnovení

Cause

K tomuto problému docházelo v prostředí, kde se server NetWorker již mnoho měsíců nerestartoval. Podezřelou příčinou jsou zastaralé certifikáty používané mezi serverem NetWorker a systémem vProxy. 

Resolution

Resetujte certifikáty používané serverem NetWorker.

  1. Po zobrazení výzvy se zvýšenými oprávněními na serveru NetWorker zastavte služby NetWorker:

Linux: nsr_shutdown nebo systemctl stop networker
Windows: net stop nsrexecd /y

 

  1. Přesuňte následující soubory do jiného adresáře na hostiteli:

Linux:

/nsr/sec/authcerts/SERVER-NAME_9090
/nsr/sec/authcerts/SERVER-NAME.cacert

Windows (výchozí):

C:\Program Files\EMC NetWorker\nsr\sec\authcerts\SERVER-NAME_9090
C:\Program Files\EMC NetWorker\nsr\sec\authcerts\SERVER-NAME.cacert 

 

  1. Restartujte server NetWorker.
POZNÁMKA: Hostitel musí být restartován. Opětovné spuštění služeb problém nevyřeší. 

 

  1. Po restartování hostitele spusťte z příkazového řádku se zvýšenými oprávněními následující příkaz: nsrauthtrust -H NETWORKER_SERVER_NAME -P 9090

Tento příkaz znovu vytvoří /nsr/sec/authcerts/SERVER-NAME_9090 .

 

  1. Restartujte zálohy virtuálních počítačů.

Pokud selhání zálohování přetrvávají, může být nutné znovu zaregistrovat virtuální proxy servery, aby se resetoval certifikát na hostiteli vProxy: NVP vProxy: Jak zrušit/znovu zaregistrovat zařízení
vProxyOpětovná registrace serveru vProxy přidá /nsr/sec/authcerts/SERVER-NAME.cacert zpět na server NetWorker.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000410390
Article Type: Solution
Last Modified: 31 Dec 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.