Avamar: Downloader Service does not support proxy authentication

Summary: Avamar Downloader does not work correctly through a proxy server which requires authentication.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Avamar Downloader Service (ADS) is installed and configured to use a proxy server to access the Internet.

The personal computer's 'Internet Options' screen is also configured to use the proxy. It allows web browsers to access the Internet through standard port 8080.  

If ADS checks for file updates, a manifest.xml file is written to the local ADS repository. No errors are reported in the ADS log and ADS believes it has successfully downloaded the manifest.xml file.  

However, the file contents are invalid as they have been replaced with the following text:
<HEAD><TITLE>Proxy Authorization Required</TITLE></HEAD> <BODY BGCOLOR="white" FGCOLOR="black"><H1>Proxy Authorization Required</H1><HR> <FONT FACE="Helvetica,Arial"><B> Description: Authorization is required for access to this proxy</B></FONT> <HR> <!-- default "Proxy Authorization Required" response (407) --> </BODY>
 
There appears to be a problem with the Avamar Downloader Server authenticating to the proxy.

Regular web browsers can correctly download the Avamar manifest.xml.

The proxy server requires clients to authenticate to it using a valid domain user's credentials.

Cause

The Avamar Downloader Service does not support proxy authentication.  

Resolution

Avamar Downloader Service is incompatible with proxies which require authentication.

A workaround may be possible if the proxy server can exclude clients from the authentication mechanism based on MAC or IP address. Work with the proxy administrators to determine if this feature is available.

Additional Information

Typical location of the Avamar Downloader Service repository
C:\Program Files\EMC\Avamar Downloader Service\repository

Typical location for Avamar Downloader Service logs
C:\Program Files\EMC\Avamar Downloader Service\var\log\AvamarDownloaderService.log

The CheckManifestThreadProc process starts. It completes with no errors or warnings reported.
14/10/2013 09:27:45 [4436] CheckManifestThreadProc started
14/10/2013 09:27:45 [4436] curlFTPFetchFile(url=<link>,filename=C:\Program Files\EMC\Avamar Downloader Service\repository\manifest.xml~,checksum=,size=322)
14/10/2013 09:27:45 [4436] curlFTPFetchFile completed(url=<link>,filename=C:\Program Files\EMC\Avamar Downloader Service\repository\manifest.xml~,checksum=,bytes read=322)
14/10/2013 09:27:45 [4436] SendFile(filename=C:\Program Files\EMC\Avamar Downloader Service\repository\manifest.xml,checksum=,hostname=avamar.customer.com,size=322)
14/10/2013 09:27:50 [4436] SendFile completed(filename=C:\Program Files\EMC\Avamar Downloader Service\repository\manifest.xml,checksum=,hostname=avamar.customer.com,bytes sent=322)
14/10/2013 09:27:50 [4436] CheckManifestThreadProc finished

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000164577
Article Type: Solution
Last Modified: 04 Jun 2024
Version:  6
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