VNX: Jak vyměnit nebo proaktivně nahradit vadný či selhávající disk trezoru v poli VNX2 (oprava společností Dell EMC)

Summary: Jak vyměnit nebo proaktivně nahradit vadný či selhávající disk trezoru v poli VNX2

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Vydat:
Jednotka trezoru v poli VNX MCx selhala a byla uložena do jiného umístění.  Jak může zákazník přesunout data zpět na disk trezoru, pokud vytvořil napříč disky trezoru uživatelské jednotky LUN? 

U trvalých náhrad není k dispozici automatická vyrovnávací operace obnovy.  Pokud dojde k selhání a výměně běžného disku, neproběhne automatické vyrovnání dat z trvalé náhrady zpět na vyměněný disk.  Náhrada za dříve poškozený disk je nyní součástí skupiny RAID.

Při výměně vadného disku trezoru dojde k naformátování nového disku a opětovnému vytvoření soukromého prostoru z jiných disků trezoru. Pokud však zákazník vytvořil na disku trezoru skupinu RAID/LUN, data LUN se nezkopírují zpět.  Zůstanou na disku, na kterém byla znovu vytvořena.  Chcete-li data zkopírovat zpět do původního umístění ručně, bude nutné použít příkaz naviseccli copytodisk.  

Informace:
Jednotky trezoru u nové generace VNX2 jsou první 4 disky v poli; 0_0, 0_1, 0_2 a 0_3.  
Každý disk trezoru bude potřebovat přibližně 300 GB volného místa v soukromém prostoru pro kód MCx a další data související s polem. 

I když se nedoporučuje umístit jednotky LUN zákazníka do trezoru, někteří zákazníci to dělají. 

Cause

Úložiště VNX nové generace nemůže vyrovnat ani obnovit zákaznická data, která byla vytvořena v jednotkách trezoru.  Při výměně jednotky trezoru se naformátuje nová jednotka a znovu se vytvoří soukromý prostor z jiných jednotek trezoru. Zákaznická data LUN se však nezkopírují zpět. Chcete-li data zkopírovat zpět do původního umístění ručně, bude nutné použít příkaz naviseccli copytodisk.

Resolution

1. scénář:  Disk trezoru je nefunkční a byl již trvale vyměněn za jiný disk v poli.  Chcete-li data zákazníka vyrovnat zpět do původního umístění trezoru, postupujte následovně:
Pomocí příkazu naviseccli copytodisk spustíte kopírování dat z nakonfigurovaného disku (součást skupiny RAID) na nevázaný disk. Tento příkaz může uživatel použít ke zkopírování dat z libovolného vázaného disku na jakýkoli nevázaný disk, a to nejen z trvalé náhrady na záložní disk.
V tomto příkladu kopírujeme z disku 0_1_5 na 0_0_2.

naviseccli -h <ipaddress> copytodisk 0_1_5 0_0_2
UPOZORNĚNÍ: The data from Source disk 0_1_5 will be copied to Destination disk 0_0_2. This process cannot be aborted and may take a long time to complete.

would you like to continue the copy? (y/n) y

Copy Back operation will then be initiated.

2. scénář: Zprávy poukazují na selhání disku.  Jak proaktivně vyměnit vadný disk trezoru ve slotech 0, 1, 2, 3 na sběrnici 0

  1.  Vyjměte všechny nevázané disky v poli (děláme to proto, že jakýkoliv nevázaný disk se v poli VNX2 může stát trvalou náhradou / jednotkou hotspare).
  2. Než budete pokračovat, zkontrolujte disky v rozhraní Unisphere nebo Naviseccli v pozici slotu 0, 1, 2, 3 a zkontrolujte, že u této sady disků nedochází k dvojité chybě. 
  3. Po uplynutí 5 minut vložte do slotu nový disk. Aby došlo k úplné obnově jednotek LUN zákazníka na disku trezoru, je nutné disk odebrat alespoň na dobu 5 minut.Počkejte alespoň 5 minut**3 Odeberte vadný nebo podezřelý disk ze slotu.
  4.  Nový disk přejde do režimu online a znovu vytvoří jednotky LUN uživatele (pokud byly jednotky LUN uživatele nakonfigurovány na discích trezoru) z ostatních disků trezoru.


Poznámka ** Velmi důležité nechat vyjmutý disk alespoň 5 minut
Flare umožňuje, aby byl disk v redundantní skupině RAID offline po dobu až 5 minut, zatímco se na tento disk protokolují vstupně-výstupní operace. Skutečná I/O se nezaznamenají. Bitmapa slouží ke sledování znečištěných rozsahů adres disku. Pokud se stejný disk znovu zpřístupní během 5 minut, protokol obnovení se použije k rychlému obnovení disku, jako je tomu v tomto případě. Tato situace se označuje jako rozdílové obnovení. Po odebrání disku na dobu delší než 5 minut dojde k úplnému obnovení jednotek LUN z ostatních disků trezoru.  Pokud nejsou na discích trezoru nakonfigurovány žádné jednotky LUN uživatele, nebude je nutné obnovovat.

Affected Products

VNX2 Series

Products

VNX5200
Article Properties
Article Number: 000029126
Article Type: Solution
Last Modified: 17 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.