NVP-vProxy: Virtual Machine Instant Recovery fails, indicating there is insufficient disk space on the datastore
Summary: NetWorker VMware Protection (NVP) vProxy Instant Access restore of a Virtual Machine (VM) fails. The error stats that there is insufficient space on the target datastore.
Symptoms
The NetWorker VMware Protection (NVP) integration is configured with the vProxy Appliance. The NetWorker Management Console (NMC) is being used to configure a virtual machine instant recovery session. The recovery session fails, indicating there is insufficient disk space on the target data store.
The NMC recovery session window and recovery log show:
159373:nsrvproxy_recover: vProxy Log: YYYY/MM/DD HH:MM:SS NOTICE: [6] Reconfiguring virtual 1 disk/s. 159373:nsrvproxy_recover: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [6] Working on disk Hard disk 1: Key: 2000 BackingType: THIN 159373:nsrvproxy_recover: vProxy Log: YYYY/MM/DD HH:MM:SS TRACE: [6] VMDK backing filename is being reconfigured to be: "[DATA_STORE_NAME] [VIRTUAL_MACHINE_NAME]/[VIRTUAL_MACHINE_NAME].vmdk" with the size 41943040 159373:nsrvproxy_recover: vProxy Log: YYYY/MM/DD HH:MM:SS INFO: [6] Task to reconfigure new vm started.... 159373:nsrvproxy_recover: vProxy Log: YYYY/MM/DD HH:MM:SS ERROR: [6] Task to reconfigure new VM failed with error Insufficient disk space on datastore '[VPROXY_NAME]'. 159373:nsrvproxy_recover: vProxy Log: YYYY/MM/DD HH:MM:SS WARN: [6] RecoverVMSessions "InstanceRecover" cleaning up running recover session due to error.
The vSphere "reconfigure virtual machine" task also shows a failed status with details of "Insufficient disk space on datastore." The recovery of a virtual machine with smaller virtual disks (vmdk's) completes as expected.
Cause
The VM instant recovery session creates a Network File System (NFS) Data Store on the Data Domain and presents it to the ESXi hosts. The free space on the Data Domain system must be equal to, or greater than, the total disk size of the virtual machine being restored. VM creation checks the target datastore size but ignores post-deduplication space on Data Domain. This may cause space validation to appear inaccurate. If there is insufficient disk space on the target NFS data store, the creation of the target virtual machine fails.
Resolution
The Data Domain file system utilization should be evaluated to see if space may be reclaimed space. The instant recovery session completes when free space on the Data Domain meets or exceeds the VM’s total disk size.
Workaround:
Perform a "New VM" recovery to a VMware datastore with enough free space to match its total disk size.