Avamar: Przywracanie pliku kończy się niepowodzeniem z błędem "Unable to BackupWrite"

Summary: Przywracanie pliku kończy się niepowodzeniem z powodu błędu "Unable to BackupWrite" z powodu niewystarczających uprawnień lokalnego konta SYSTEM do zapisu w określonym folderze.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Błąd niepowodzenia przywracania.

Przywracanie plików przy użyciu wtyczki systemu plików systemu Windows może się nie powieść i spowodować wyświetlenie poniższego błędu:

  • Operacja przywracania nie powiodła się 
  • Wyświetlany jest komunikat o błędzie
avtar Error <5737>: I/O error: Unable to BackupWrite(4)

Cause

Niewystarczające uprawnienia

Konto skonfigurowane dla usługi avagent (Backup Agent) nie ma wystarczających uprawnień do zapisu w określonym folderze.

Domyślnie usługa avagent działa z lokalnym kontem SYSTEM, które nie ma niezbędnego dostępu do odczytu/zapisu do folderu docelowego i podfolderów.

Ten problem z uprawnieniami jest wyświetlany w tym komunikacie o błędzie:

Error <5737>: I/O error: Unable to BackupWrite(4)

 

Resolution

Przywracanie funkcji tworzenia kopii zapasowej plików

Aby rozwiązać ten problem, przyznaj lokalnemu kontu SYSTEMOWEMU dostęp do odczytu/zapisu do folderu docelowego i podfolderów. Można to osiągnąć, modyfikując uprawnienia folderu.

Wykonaj następujące kroki, aby dostosować uprawnienia:

  • Odszukaj folder docelowy w Eksploratorze Windows.
  • Kliknij folder prawym przyciskiem myszy i wybierz polecenie Właściwości.
  • W oknie Właściwości przejdź do zakładki Zabezpieczenia.
  • Kliknij przycisk Edytuj , aby zmienić uprawnienia.
  • W oknie Uprawnienia kliknij przycisk Dodaj.
  • Wprowadź "SYSTEM" w polu Wprowadź nazwy obiektów do wybrania i kliknij przycisk Sprawdź nazwy.
  • Po dodaniu konta SYSTEM wybierz je i zaznacz pola wyboru uprawnień do odczytu i zapisu.
  • Kliknij przycisk Zastosuj , a następnie OK , aby zapisać zmiany.

Można również skonfigurować usługę Backup Agent tak, aby działała z kontem użytkownika domeny z co najmniej uprawnieniami do odczytu/zapisu w folderze docelowym.

  1. Konfiguracja usług Avamar:

    • Otwórz konsolę zarządzania usługami (services.msc).
    • Odszukaj usługę Avamar Backup Agent.
    • Kliknij usługę prawym przyciskiem myszy i wybierz Właściwości.
    • Przejdź do karty Logowanie.
    • Wybierz opcję To konto i wprowadź poświadczenia użytkownika domeny (nazwę użytkownika i hasło).
    • Kliknij Zastosuj, a następnie OK.
  2. Uruchom ponownie usługę: Wróć do karty Ogólne i kliknij przycisk Start , aby ponownie uruchomić usługę.

    Po zaktualizowaniu uprawnień sprawdź, czy problem został rozwiązany, próbując przywrócić pliki przy użyciu wtyczki systemu plików systemu Windows.

    Jeśli problemy nie ustąpią, skontaktuj się z pomocą techniczną firmy Dell.

    Affected Products

    Avamar Client for Windows

    Products

    Avamar, Avamar Client
    Article Properties
    Article Number: 000030795
    Article Type: Solution
    Last Modified: 20 May 2025
    Version:  4
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.