Avamar: Dosya geri yüklemesi "Unable to BackupWrite" hatasıyla başarısız oluyor

Summary: Dosya geri yüklemesi, yerel SYSTEM hesabının belirtilen klasöre yazma izinlerinin yetersiz olması nedeniyle "Unable to BackupWrite" hatasıyla başarısız oluyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Geri yükleme hatası hatası.

Windows File System eklentisini kullanarak dosyaların geri yüklemesi başarısız olabilir ve aşağıdaki hataya neden olabilir:

  • Geri yükleme işlemi başarısız oluyor 
  • Hata mesajı görüntülenir
avtar Error <5737>: I/O error: Unable to BackupWrite(4)

Cause

Yetersiz İzinler

Avagent (Backup Agent) hizmeti için yapılandırılan hesap, belirtilen klasöre yazmak için yeterli izinlere sahip değil.

Varsayılan olarak avagent hizmeti, hedef klasöre ve alt klasörlere gerekli okuma/yazma erişimi olmayan yerel SYSTEM hesabıyla çalışır.

Bu izin sorunu şu hata iletisinde gösterilir:

Error <5737>: I/O error: Unable to BackupWrite(4)

 

Resolution

Dosya Yedekleme İşlevini Geri Yükleme

Sorunu çözmek için yerel SYSTEM hesabına hedef klasör ve alt klasörler için okuma/yazma erişimi verin. Bu, klasör izinlerini değiştirerek gerçekleştirilebilir.

İzinleri ayarlamak için şu adımları izleyin:

  • Windows Gezgini'nde hedef klasörü bulun.
  • Klasöre sağ tıklayın ve Özellikler'i seçin.
  • Özellikler penceresinde Güvenlik sekmesine gidin.
  • İzinleri değiştirmek için Edit öğesine tıklayın.
  • Permissions penceresinde Add öğesine tıklayın.
  • Enter the object names to select alanına "SYSTEM" yazın ve Adları Denetle öğesine tıklayın.
  • SYSTEM hesabı eklendikten sonra bu hesabı seçin ve Okuma ve Yazma izinleri kutularını işaretleyin.
  • Değişiklikleri kaydetmek için Uygula'ya ve ardından Tamam'a tıklayın.

Alternatif olarak, Backup Agent hizmetini, hedef klasörde en az okuma/yazma ayrıcalıklarına sahip bir etki alanı kullanıcı hesabıyla çalışacak şekilde yapılandırın.

  1. Avamar hizmetlerini yapılandırın:

    • Hizmetler yönetim konsolunu (services.msc) açın.
    • Avamar Backup Agent hizmetini bulun.
    • Hizmete sağ tıklayın ve Properties öğesini seçin.
    • Oturum Açma sekmesine gidin.
    • This account öğesini seçin ve etki alanı kullanıcı kimlik bilgilerini (username ve password) girin.
    • Uygula'ya ve ardından Tamam'a tıklayın.
  2. Hizmeti yeniden başlatın: Genel sekmesine geri dönün ve hizmeti yeniden başlatmak için Başlat'a tıklayın.

    İzinleri güncelleştirdikten sonra Windows File System eklentisini kullanarak dosyaları geri yüklemeyi deneyerek sorunun çözüldüğünü doğrulayın.

    Sorunlar devam ederse destek için Dell Desteği ile iletişime geçin.

    Affected Products

    Avamar Client for Windows

    Products

    Avamar, Avamar Client
    Article Properties
    Article Number: 000030795
    Article Type: Solution
    Last Modified: 20 May 2025
    Version:  4
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.