NVP – vProxy: Selhání zálohování "Client 'vCenter' is not properly configured on the NetWorker Server"
Summary: Nelze zálohovat virtuální počítače (VM) pomocí řešení NetWorker VMware Protection (NVP) vProxy. Zálohování se nezdaří a hlásí, že nástroj vCenter není na serveru NetWorker správně nakonfigurován. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Všechny zdroje klienta vCenter byly odstraněny.
Zálohování všech serverů vProxy selhalo s chybou:
Zálohování všech serverů vProxy selhalo s chybou:
MM/DD/YYYY HH:mm:SS Backup failed. MM/DD/YYYY HH:mm:SS Unable to process VM 'vmname': Client 'vcenter' is not properly configured on the NetWorker Server or 'vcenter'(if not a virtual host) is not in the aliases list for client 'networker server' MM/DD/YYYY HH:mm:SS vmname: Backup failed. MM/DD/YYYY HH:mm:SS Final Summary of VMs: MM/DD/YYYY HH:mm:SS 0 canceled backups MM/DD/YYYY HH:mm:SS X failed backups MM/DD/YYYY HH:mm:SS 0 successful backups MM/DD/YYYY HH:mm:SS 0 waiting backups MM/DD/YYYY HH:mm:SS 0 running backups MM/DD/YYYY HH:mm:SS 0 savesets output to next action MM/DD/YYYY HH:mm:SS Action has finished with failures. MM/DD/YYYY HH:mm:SS Action backup vmware-vproxy 'Backup' with job id jobid is exiting with status 'failed', exit code 1
Cause
Zdroj klienta vCenter v nástroji NetWorker neexistuje. Veškerý zdroj klienta vCenter byl odebrán z konzole NMC v domnění, že nástroj vCenter není pro zálohování potřeba.
Resolution
NetWorker VMware Protection (NVP) používá pro každý nástroj VMware vCenter nakonfigurovaný v nástroji NetWorker jeden zdroj klienta. Zálohy virtuálních počítačů se zobrazují jako sady pro ukládání v rámci prostředku klienta vCenter. Zde je příklad, jak se záloha virtuálního počítače zobrazuje v databázi médií NetWorker.
Pokud problém přetrvává, je nutné odebrat zdroj hypervisoru (vCenter) z platformy NetWorker a znovu jej přidat. NetWorker: Odebrání položky vCenter z NMC VMware View/Odebrání hypervisoru NSR
vm:vmware-vm-uuid:vcentername
Příklad:
[root@nsr ~]# mminfo -kvot volume type client date time size ssid fl lvl name ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/19/2025 06:00:18 PM 94 GB 4191895152 cr full vm:503e178f-6982-0b07-36b2-c46c6d3ec4c9:vcsa.amer.lan ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:25 PM 41 GB 4259072246 cr full vm:503edaab-e481-b0e7-1433-835e23dd2a5d:vcsa.amer.lan ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:26 PM 94 GB 4242295030 cr full vm:503e178f-6982-0b07-36b2-c46c6d3ec4c9:vcsa.amer.lan ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:27 PM 188 GB 4225517814 cr full vm:503e7439-7053-9fc0-6c26-02f5f021b289:vcsa.amer.lan
Zdroj klienta vCenter by neměl být odstraněn z NetWorker. Znovu vytvořte všechny zdroje klienta vCenter a obnovte zálohování.
Vytvořte nového klienta v NMC pro nástroj vCenter pomocí plně kvalifikovaného názvu vCenter.
- Otevřete na serveru NetWorker příkazový řádek správce nebo relaci kořenového protokolu SSH.
- Přejděte do příkazového řádku nsradmin :
nsradmin
- V příkazovém řádku nsradmin vytvořte pomocí příkazu "create type" nový zdroj klienta pro server vCenter pomocí jeho plně kvalifikovaného názvu domény (FQDN):
create type: nsr client; name: <VCENTER_FQDN>; backup type: vProxy
Příklad:
nsradmin> create type: nsr client; name: vcsa.amer.lan; backup type: vProxy
type: NSR client;
name: vcsa.amer.lan;
backup type: vProxy;
Create? y
created resource id 52.0.169.11.0.0.0.0.218.150.219.103.192.168.9.150(1)
nsradmin>
- Zkuste zálohování zopakovat.
Pokud problém přetrvává, je nutné odebrat zdroj hypervisoru (vCenter) z platformy NetWorker a znovu jej přidat. NetWorker: Odebrání položky vCenter z NMC VMware View/Odebrání hypervisoru NSR
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000034174
Article Type: Solution
Last Modified: 20 Mar 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.