NVP-vProxy : Échec de la sauvegarde « Le client 'vCenter' n’est pas correctement configuré sur le NetWorker Server »
Summary: Impossible de sauvegarder les machines virtuelles (VM) à l’aide de la solution NetWorker VMware Protection (NVP) vProxy. La sauvegarde échoue, signalant que vCenter n’est pas correctement configuré sur le NetWorker Server. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Toutes les ressources client vCenter ont été supprimées.
Échec de la sauvegarde de tous les vProxy avec l’erreur :
Échec de la sauvegarde de tous les vProxy avec l’erreur :
MM/DD/YYYY HH:mm:SS Backup failed. MM/DD/YYYY HH:mm:SS Unable to process VM 'vmname': Client 'vcenter' is not properly configured on the NetWorker Server or 'vcenter'(if not a virtual host) is not in the aliases list for client 'networker server' MM/DD/YYYY HH:mm:SS vmname: Backup failed. MM/DD/YYYY HH:mm:SS Final Summary of VMs: MM/DD/YYYY HH:mm:SS 0 canceled backups MM/DD/YYYY HH:mm:SS X failed backups MM/DD/YYYY HH:mm:SS 0 successful backups MM/DD/YYYY HH:mm:SS 0 waiting backups MM/DD/YYYY HH:mm:SS 0 running backups MM/DD/YYYY HH:mm:SS 0 savesets output to next action MM/DD/YYYY HH:mm:SS Action has finished with failures. MM/DD/YYYY HH:mm:SS Action backup vmware-vproxy 'Backup' with job id jobid is exiting with status 'failed', exit code 1
Cause
La ressource client vCenter n’existe pas dans NetWorker. Toutes les ressources client vCenter ont été supprimées de NMC, pensant que vCenter n’est pas nécessaire pour la sauvegarde.
Resolution
NetWorker VMware Protection (NVP) utilise une ressource client unique pour chaque VMware vCenter configuré dans NetWorker. Les sauvegardes de machines virtuelles s’affichent sous forme de savesets au sein de la ressource client vCenter. Voici un exemple de la façon dont une sauvegarde de machine virtuelle s’affiche dans la base de données des médias NetWorker.
Si le problème persiste, vous devez supprimer la ressource Hyperviseur (vCenter) de NetWorker et la rajouter. NetWorker : Suppression de l’entrée vCenter de NMC VMware View/suppression de l’hyperviseur NSR
vm:vmware-vm-uuid:vcentername
Exemple :
[root@nsr ~]# mminfo -kvot volume type client date time size ssid fl lvl name ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/19/2025 06:00:18 PM 94 GB 4191895152 cr full vm:503e178f-6982-0b07-36b2-c46c6d3ec4c9:vcsa.amer.lan ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:25 PM 41 GB 4259072246 cr full vm:503edaab-e481-b0e7-1433-835e23dd2a5d:vcsa.amer.lan ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:26 PM 94 GB 4242295030 cr full vm:503e178f-6982-0b07-36b2-c46c6d3ec4c9:vcsa.amer.lan ddve01VMbackup.001 Data Domain vcsa.amer.lan 03/20/2025 12:57:27 PM 188 GB 4225517814 cr full vm:503e7439-7053-9fc0-6c26-02f5f021b289:vcsa.amer.lan
La ressource client vCenter ne doit pas être supprimée de NetWorker. Recréez toutes les ressources du client vCenter et reprenez la sauvegarde.
Créez un nouveau client dans NMC pour le vCenter en utilisant le nom complet du vCenter.
- Ouvrez une invite de commande de l’administrateur ou une session SSH root sur le NetWorker Server.
- Saisissez l’invite nsradmin :
nsradmin
- À partir de l’invite nsradmin , utilisez la commande create type pour créer une ressource client pour le vCenter Server à l’aide de son nom de domaine complet (FQDN) :
create type: nsr client; name: <VCENTER_FQDN>; backup type: vProxy
Exemple :
nsradmin> create type: nsr client; name: vcsa.amer.lan; backup type: vProxy
type: NSR client;
name: vcsa.amer.lan;
backup type: vProxy;
Create? y
created resource id 52.0.169.11.0.0.0.0.218.150.219.103.192.168.9.150(1)
nsradmin>
- Réessayez les sauvegardes.
Si le problème persiste, vous devez supprimer la ressource Hyperviseur (vCenter) de NetWorker et la rajouter. NetWorker : Suppression de l’entrée vCenter de NMC VMware View/suppression de l’hyperviseur NSR
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000034174
Article Type: Solution
Last Modified: 20 Mar 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.